Opened 9 years ago

Closed 8 months ago

Last modified 8 months ago

#1803 closed defect (fixed)

trac link with subdirectory access

Reported by: anonymous Owned by: Committo-Ergo-Sum
Priority: normal Component: DoxygenPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10


When I access a Doxygen Trac link which points to a file in a subdirectory, a 404 Not Found error occurs. There is an automatic transformation from a slash (/) to a backslash (\) wich causes the error (see error message).

[doxygen:directory/subdirectory/file] -> error

[doxygen:directory/file] -> works

Error message:

The requested URL /trac/myproject/doxygen/directory\subdirectory/file was not found on this server.

Direct access with a correct slash (/trac/myproject/doxygen/directory/directory/file) works.

Webserver - Apache 2.0.59 + mod_python 3.3.1
Trac 0.10.4 + doxygen 0.4
Python 2.4.4
OS - Win 2003 Server

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by anonymous

I can confirm this bug. I've also seen this come up using apache and python on windows (*not* using cygwin)

comment:2 Changed 7 years ago by alecann

I have the same problem.

I have inserted the following code in file after the line 279:

Last edited 8 months ago by rjollos (previous) (diff)

comment:3 Changed 7 years ago by cboos

Can you try with the very latest version? This ticket looks like a duplicate of #5588, fixed today.

comment:4 Changed 7 years ago by anonymous

It's OK with the latest version.

comment:5 Changed 7 years ago by alecann

It's OK with the latest version

comment:6 Changed 8 months ago by Committo-Ergo-Sum

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 8 months ago by rjollos

  • Owner changed from cboos to Committo-Ergo-Sum

Add Comment

Modify Ticket

as closed The owner will remain Committo-Ergo-Sum.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.