Modify

Opened 10 years ago

Closed 10 years ago

#1925 closed task (fixed)

WebAdmin required to use ThemeEnginePlugin

Reported by: joe_merchant@… Owned by: Noah Kantrowitz
Priority: high Component: ThemeEnginePlugin
Severity: minor Keywords: documentation dependency reference
Cc: Trac Release: 0.10

Description

After turning on debug logging, I discovered that the ThemeEnginePlugin needs WebAdmin to function (and of course, I did not have the WebAdmin plugin installed).

Even knowing this, I still don't see anything in the documentation that tells that WebAdmin is a required dependency for ThemeEnginePlugin to work.

The themes documentation points very helpfully to ThemeEnginePlugin as a dependency, it would have saved two developers some time helping me (and me a good bit of time debugging) if the ThemeEnginePlugin had simply told me in its documentation that it needs WebAdmin, instead of failing to load with no more notice than a message to the log file (which I have never had to use until now....)

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by Noah Kantrowitz

Resolution: fixed
Status: newclosed

Done

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.