Modify

Opened 10 years ago

Closed 10 years ago

#1933 closed defect (wontfix)

blocking string matches unintended tickets

Reported by: jeffnorman Owned by: Noah Kantrowitz
Priority: normal Component: MasterTicketsPlugin
Severity: major Keywords:
Cc: Trac Release: 0.10

Description

Setting the blocking field of a ticket to "22" will block the tickets 22 and 2. Similarly, setting the blocking field of a ticket to "14" will block ticket 14 and 4.

I would guess that setting the blocking field to "212" would block ticket 212, 12, and 2, but I didn't test with a system containing that many tickets.

I haven't dug into the code for a solution yet, but I'd imagine that the problem is caused because a ticket's id matched as a string only against the end of the blocking field string, disregarding any part of the string that is longer than the current id's string.

I'd suggest making the match numeric, if possible.

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by Noah Kantrowitz

Resolution: wontfix
Status: newclosed

The 0.10 version suffers from many systemic issues (this being the most noticeable). The new 0.11 version has been totally redesigned, but due to personal time constraints I am not backporting it any time soon.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.