Modify

Opened 16 years ago

Closed 3 years ago

#195 closed defect (duplicate)

Poll macro doesn't track session/ip

Reported by: anonymous Owned by: Ryan J Ollos
Priority: normal Component: PollMacro
Severity: normal Keywords:
Cc: Trac Release: 0.8

Description

If you select a vote, click the vote button and then hit refresh, the vote will be counted twice, hit refresh again, and it'll be tallyed again, and so on. A properly motivated individual can easily skew any results by doing this.

Attachments (0)

Change History (6)

comment:1 Changed 16 years ago by Noah Kantrowitz

Tracking against session won't easily work with anonymous users, or those that block cookies. Tracking against IP doesn't work these days because of NAT. What might be more usable is an option to restrict voting to logged-in users only.

comment:2 Changed 16 years ago by Alec Thomas

Yeah, this has been a problem since day dot and I reached the same conclusion as coderanger.

comment:3 Changed 12 years ago by Ryan J Ollos

Owner: changed from Alec Thomas to Ryan J Ollos
Trac Release: 0.8

Reassigning ticket to new maintainer.

comment:4 Changed 12 years ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

Voting is now restricted to users that have registered a session.

comment:5 in reply to:  4 Changed 12 years ago by Ryan J Ollos

Resolution: fixed
Status: closedreopened

Replying to rjollos:

Voting is now restricted to users that have registered a session.

Confused this with the vote macro ... this is not yet implemented, but this is the feature that I think we need to implement.

comment:6 Changed 3 years ago by Ryan J Ollos

Resolution: duplicate
Status: reopenedclosed

Closing as duplicate of #10703, which has a patch.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.