Modify

Opened 10 years ago

Closed 4 years ago

#1986 closed defect (wontfix)

Wrong fields hided from the ticket view, after it's creation

Reported by: Florian Seydoux Owned by: Noah Kantrowitz
Priority: normal Component: CondFieldsPlugin
Severity: normal Keywords: IE7 DISPLAY
Cc: Trac Release: 0.10

Description

Hello,
I've tried to use this interesting plugin, but unfortunately I encounter some issues (as you can imagine).

I have a set of custom fields for my trac site, and they are correctly hided, accordingly to the ticket type, when a new ticket is created; but when I go back to a previously created ticket, fields that I should see are hided (some of them), and fields that I should'nt see (cc, keywords and assigned to) are showed.

Also, any other (minor) issue (hum... I probably should create separate tickets for that, but): with IE7, the hiding process doesn't work (as far as I can see, javascript is enabled, but IE complain about "error" on page:

Error: 'condfields[...]' is null or not an object
Code:0

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by anonymous

To solve the IE7 problem:

change condfields.cs:

    //set_type($('#type').val());
    set_type($('#type').get(0).options[$('#type').get(0).selectedIndex].text);
    
    $('#type').change(function() {
        //set_type($(this).val());
        set_type(this.options[this.selectedIndex].text);
    })

comment:2 Changed 10 years ago by anonymous

Impovement to avoid an error in other pages:

    if($('#type').size()>0) {
      set_type($('#type').get(0).options[$('#type').get(0).selectedIndex].text);
    
      $('#type').change(function() {
        set_type(this.options[this.selectedIndex].text);
      });
    }

comment:3 in reply to:  2 Changed 10 years ago by Florian Seydoux

Replying to anonymous:

Impovement to avoid an error in other pages: [...]

Yeah. it works fine - thanks a lot.

comment:4 Changed 10 years ago by steve@…

Regarding this patch - worked perfectly for me too. IE6 also picks up this problem so this fix was essential.

Regarding the original ticket - I cannot reproduce the problem.

comment:5 in reply to:  4 Changed 9 years ago by Florian Seydoux

Replying to steve@t220.com: [...]

Regarding the original ticket - I cannot reproduce the problem.

Effectively. It seems that it was due to a conflict with another plugin (but which one, I don't know for the moment). By deactivating almost all of the one that I have in my test site, the fields are now correctly filtered. I'll try to detect the (set of) plugin(s) who cause the conflict...

comment:6 Changed 4 years ago by Ryan J Ollos

Resolution: wontfix
Status: newclosed

The 0.10 version of this plugin is no longer supported. If you can reproduce the issue with the 0.11 branch and Trac 0.11 or later, please create a new ticket and I will promptly fix the issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.