Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2205 closed defect (fixed)

TimingAndEstimationPlugin Plugin Errors

Reported by: awzm Owned by: Russ Tyndall
Priority: normal Component: TimingAndEstimationPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11


Following on from ticket #2192 ( I'm still have trouble running this plugin. I upgraded to the newest Genshi and used TracPlugins to extract the .egg file and put in the plugins directory. I added the new line to trac.ini and used the upgrade command. When I start up tracd and go to http://localhost:8000/ my project environment isn't listed. My cmd windows states..

raise UndefinedError(key, owner=owner) Undefined Error: {'name': ProjectName', 'description': u'The Trac Environment needs to be upgraded. \n\nRun "trac-admin C:
Projectfolder upgrade";} has no member named href"

I've already used the upgrade command only for it to make no difference. I followed the instructions on TracPlugins & TimingAndEstimationPlugin Installation to the word.

Thanks :)

Attachments (3)

trac.log (5.5 KB) - added by awzm 11 years ago.
log file
traceback.JPG (83.1 KB) - added by awzm 11 years ago.
Traceback from cmd
tracv2.log (33.5 KB) - added by awzm 11 years ago.
trac v2 log

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by Russ Tyndall

  • Does trac work without the plugin installed?
    • Remove the line from the trac.ini and pull the egg out of the plugin directory to be sure. I want to make sure that the problem is with the plugin.
  • I dont have any experience with tracd, is it reporting the same error messages as the trac log? Normally an error refers to some place in code, instead of a referencing "Env Needs to Be Upgraded"
  • the only error I raise in the whole plugin is in report manager we raise a single TracError and I have verified that that error type exists. Also I think that this error is not possible to hit (because it is only raised with conflicting versions of that file and there is only one version of that file available)
  • Are you getting any other tracebacks?

comment:2 Changed 11 years ago by awzm

I started from the beginning and this is what I get.

  1. Remove .egg file and line from trac.ini and boot up tracd. Trac works fine.
  2. Start up tracd and start logging (Type: File, Log Level: Error). Stop tracd.
  3. Put the .egg file in plugins dir and put the line in trac.ini
  4. Run trac-admin /path/to/projenv upgrade and get the expected return.
  5. Start tracd back up and go to http://localhost:8000 to find a blank screen
  6. Go to http://localhost:8000/projectname to find the error message: "Trac Error -

TracError: The Trac Environment needs to be upgraded. - Run "trac-admin c:\essentialtravel upgrade" ".

  1. Stop tracd.

I've attached a screenshot of the last traceback in cmd and my log file. Hope that helps.

Changed 11 years ago by awzm

Attachment: trac.log added

log file

Changed 11 years ago by awzm

Attachment: traceback.JPG added

Traceback from cmd

comment:3 Changed 11 years ago by Russ Tyndall

Resolution: fixed
Status: newclosed

(In [2813]) closes #2205

Fixed bug in report manager where it was throwing an error while trying to (None+1).

T&E trac11 version 0.5.5

comment:4 Changed 11 years ago by Russ Tyndall

Thank you very much for your persistence in helping me track down this bug. The trac log gave me everything I needed to locate and exterminate this bug. Hopefully it will be the last you have to deal with in this process.


comment:5 Changed 11 years ago by awzm

Resolution: fixed
Status: closedreopened

Sorry to be a pain but that change doesn't seem to have fixed it. As before I started from fresh and did everything to get the plugin working. I get the same blank screen when trying to list the project environments and the same error message when trying to access the project environment I setup.

I've attached the new log file ('tracv2.log') so you can see what errors are coming up. It looks like SQL errors but I'm no expert. It may help you to note that I'm using pysqlite-2.3.5.win32-py2.5

Thanks for all the time and effort you're putting to getting this fixed :)

Changed 11 years ago by awzm

Attachment: tracv2.log added

trac v2 log

comment:6 Changed 11 years ago by Russ Tyndall

I was out of town over the weekend and I am looking at this now.

comment:7 Changed 11 years ago by Russ Tyndall

Resolution: fixed
Status: reopenedclosed

(In [2823]) closes #2205 TandE (trac11) version 0.5.6

Fixed a few bugs related to starting an environment from scratch. Fixed a bug in get scalar that caused every execute to fail.

comment:8 Changed 11 years ago by awzm

thanks for the continued help with the plugin bobbysmith007 :)

i'll give the new version a go this afternoon

comment:9 Changed 11 years ago by Russ Tyndall

no problem. I am sorry this didnt get as thoroughly tested as it could have been.

I have installed this version of the plugin from scratch, so hopefully this one actually works!

If it fails please reopen the ticket and post your logfile again.

Thanks for your help debugging this matter,


Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Russ Tyndall.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.