Opened 10 years ago

Closed 10 years ago

#2411 closed task (worksforme)

Installation problem

Reported by: david.barnhill@… Owned by: Noah Kantrowitz
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11


I am not able to install the MasterTicketPlugin. I have recently installed TRAC 0.11b1. When I try to install I get the following:

[root@localhost 0.11]# python ./ 
usage: [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: --help [cmd1 cmd2 ...]
   or: --help-commands
   or: cmd --help

error: no commands supplied

What am I doing wrong?

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by david.barnhill@…

After a little bit of additional reading about how to setup TRAC, I was able to get a little further in the installation. The installation is complaining about the version of Genshi

[root@localhost 0.11]# easy_install ./
Running -q bdist_egg --dist-dir /tmp/masterticketsplugin/0.11/egg-dist-tmp-UTrZ3D
zip_safe flag not set; analyzing archive contents...
Adding TracMasterTickets 2.1.1 to easy-install.pth file

Installed /usr/lib/python2.4/site-packages/TracMasterTickets-2.1.1-py2.4.egg
Processing dependencies for TracMasterTickets==2.1.1
Searching for Genshi==dev,>
No local packages or download links found for Genshi==dev,>
error: Could not find suitable distribution for Requirement.parse('Genshi==dev,>')

I am using the Genshi version that installed with TRAC 0.11b1

comment:2 Changed 10 years ago by Noah Kantrowitz

Resolution: worksforme
Status: newclosed

As is stated on the wiki page, you will need to install Genshi from trunk (>=0.5dev).

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.