Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2776 closed defect (wontfix)

Plugin broken for 0.11?

Reported by: Chris Owned by: Matt Good
Priority: normal Component: TracPygmentsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Using: Trac: 0.11b1 Python: 2.5 (r25:51908, Sep 19 2006, 09:52:17) [MSC v.1310 32 bit (Intel)] setuptools: 0.6c7 SQLite: 3.5.2 pysqlite: 2.4.0 Genshi: 0.4.4 Pygments: 0.9 Subversion: 1.4.6 (r28521)

I get this in the log file when I try to view a C# file: 2008-03-21 11:24:02,877 Trac[browser] DEBUG: Rendering preview of node AttExtract.cs@None with mime-type text/x-csharp; charset=iso-8859-15 2008-03-21 11:24:02,887 Trac[api] DEBUG: Trying to render HTML preview using PygmentsRenderer [lineno]

And this when trying to view a python source: 2008-03-21 11:52:00,292 Trac[browser] DEBUG: Rendering preview of node CIP.py@None with mime-type text/x-python; charset=iso-8859-15 2008-03-21 11:52:00,362 Trac[api] DEBUG: Trying to render HTML preview using PygmentsRenderer [lineno]

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by Matt Good

Resolution: wontfix
Status: newclosed

0.11 includes Pygments support so just uninstall this plugin.

comment:2 Changed 9 years ago by Chris

You're right, I turned it off and it works. This wasn't clear in the install doc but I guess it still needed to be enabled in the ini, because it wasn't working out of the box.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matt Good.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.