Modify

Opened 9 years ago

Closed 9 years ago

#2995 closed defect (duplicate)

Doxygen TracLinks do not work for classes in a namespace

Reported by: mateusz@… Owned by: Christian Boos
Priority: normal Component: DoxygenPlugin
Severity: normal Keywords: TracLinks
Cc: Trac Release: 0.11

Description

We use Trac and DoxygenPlugin in libLAS project. All our classes live in namespace liblas and doxygen generates file with names like this: class liblas::guid and doxygen filename is classliblas_1_1guid.html - note the liblas part in filename.

This is causes problems with linking classes I tried to use qualified and non-qualified name but no success:

[doxygen:guid]
[doxygen:liblas::guid]

Here is one of our ticket as an example of this problem.

I've made some test with classes not defined in a namespace and here everything works well, classe names are correctly linked to corresponding doxygen pages. This assures me that the namespace part in filename of doxygen HTML page is a trouble maker here.

Thanks in advance for any comments and patches. Also, thank you for the DoxygenPlugin!

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by Radek Bartoň

Owner: changed from Radek Bartoň to Christian Boos

cboos maintains this plugin.

comment:2 Changed 9 years ago by Christian Boos

sort of... that plugin would deserve more serious attention, something I wasn't able to do since quite some time now.

comment:3 Changed 9 years ago by Radek Bartoň

I would help with it but it would mean to rewrite most of the plugin and I should pay attention to my others. Maybe during summer...

comment:4 Changed 9 years ago by Christian Boos

Resolution: duplicate
Status: newclosed

Duplicate of #780.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.