Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#308 closed defect (fixed)

Sendmail Failure following instructions

Reported by: stephen.a.cochran@… Owned by: Bas van der Vlies
Priority: normal Component: EmailtoTracScript
Severity: normal Keywords:
Cc: stephen.a.cochran@… Trac Release: 0.9


Following the default instructions, it fails on RHEL 4 using sendmail. Generates the following error:

smrsh: "run_email2trac.--project=turingTime" not available for sendmail programs (stat failed)

It's obviously a problem with the SUID run_email2trac program, but I'm not clear enough on it's purpose to have solved it yet.

One thought though, if that program is only needed for saving attachments, perhaps an option to disable attachments (which I don't want anyway) would be nice and remove the need for installing a SUID program?

WHen I find the solution I'll update this ticket

Attachments (0)

Change History (5)

comment:1 Changed 12 years ago by anonymous

Found a reference to the problem, and checking on smrsh I did the following:

ln -s /usr/local/bin/run_email2trac email2trac

and changes the alias line to

|email2trac --project=...

That's the config that works on the same system for majordomo, but I'm still getting the same error for right now.

comment:2 Changed 12 years ago by anonymous

Cc: stephen.a.cochran@… added; anonymous removed

I am not familiar with sendmail, we use postfix, did you tried to specify the whole path: |"/usr/local/bin/run_email2trac --project=...."

I will make an option to disable attachments and in the futuru test it with sendmail

comment:3 Changed 12 years ago by stephen.a.cochran@…

Yea, I hate sendmail as well.

Sendmail limits the executables that can be run via aliases to those in a special directory, and runs them using a restricted shell called smrsh. On RH, the default location for the allowed programs is /etc/smrsh.

I tried both a link in that dir to the run_email2trac file and a little shell script that simply calls run_email2trac and passes the params. Both should work, but neither did yet. Majordomo works the same way, and it set up on the machine already so I'll check on that later today.

I found a pretty good walk-through of the problem/solution at

comment:4 Changed 12 years ago by anonymous

Well, I was in fact doing the right thing. Here's all the steps to follow post make install

ln -s /usr/local/bin/run_email2trac /etc/smrsh/run_email2trac

in aliases use:

"|run_email2trac --project=..."

Note: Include the quotes, they are necessary. That got me past the sendmail problem. No ticket appeared in the project, but I'll look into that next. Is there a log generated anywhere?

comment:5 Changed 12 years ago by anonymous

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Bas van der Vlies.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.