Modify

Opened 9 years ago

Closed 7 years ago

#3091 closed defect (duplicate)

[PATCH] Error just after installing

Reported by: anonymous Owned by: Noah Kantrowitz
Priority: highest Component: ProjectMenuPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.10

Description

Traceback (most recent call last):

File "/var/lib/python-support/python2.4/trac/web/main.py", line 406, in dispatch_request

dispatcher.dispatch(req)

File "/var/lib/python-support/python2.4/trac/web/main.py", line 208, in dispatch

chrome.populate_hdf(req, chosen_handler)

File "/var/lib/python-support/python2.4/trac/web/chrome.py", line 319, in populate_hdf

for category, name, text in contributor.get_navigation_items(req):

File "build/bdist.linux-i686/egg/projectmenu/web_ui.py", line 21, in get_navigation_items File "/var/lib/python-support/python2.4/trac/web/main.py", line 58, in _open_environment

env_cache[env_path] = open_environment(env_path)

File "/var/lib/python-support/python2.4/trac/env.py", line 462, in open_environment

env = Environment(env_path)

File "/var/lib/python-support/python2.4/trac/env.py", line 147, in init

self.verify()

File "/var/lib/python-support/python2.4/trac/env.py", line 195, in verify

fd = open(os.path.join(self.path, 'VERSION'), 'r')

IOError: [Errno 20] Not a directory: '/var/lib/trac/trac.htpasswd/VERSION'

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by anonymous

It can be easily fixed by the following patch:

for project in os.listdir(search_path):

  • if project != this_project:

+ if project != this_project and os.path.isdir(os.path.join(search_path, project)):

proj_env = open_environment(os.path.join(search_path, project),use_cache=True)

comment:2 Changed 7 years ago by Adrian Fritz

Resolution: duplicate
Status: newclosed
Summary: Error just after installing[PATCH] Error just after installing

Seems to be a duplicate of #1301. If different, please reopen this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.