Modify

Opened 9 years ago

Closed 4 months ago

#3230 closed enhancement (wontfix)

Catch changes from DiscussionPlugin

Reported by: Ingmar Heinrich Owned by:
Priority: low Component: AnnouncerPlugin
Severity: minor Keywords: API
Cc: Ryan J Ollos, Odd Simon Simonsen Trac Release: 0.11

Description

It would be nice if the plugin would not only catch wiki pages but also object from other plugins.

Today I can put the General Announcement

ProductDesign/BrainStorms/*

but it would be cool if this announcement would look like

wiki/ProductDesign/BrainStorms/*

so that I could also put e. g.

discussion/2/*

to catch all posts in forum #2 from DiscussionPlugin. I might be talking crap because I don't know the show behind the curtain, but it's worth while a try :-)

Attachments (0)

Change History (12)

comment:1 Changed 9 years ago by Robert Corsaro

Owner: changed from Stephen Hansen to Robert Corsaro

This will eventually be reimplemented in core. I will consider the idea.

comment:2 Changed 9 years ago by anonymous

Severity: normalmajor

i tried to set:

watchable_paths = wiki/*,ticket/*,blog/*,discussion/*

when clicking on "discussino" or "blog" the following occurs (while on the single sub-pages, there is a "watch" button):

 Trac detected an internal error:
   ValueError: need more than 1 value to unpack

egg/announcerplugin/subscribers/watchers.py", line 134, in post_process_request:

Local variables:
content_type  	None
data 	{'dateinfo': <function dateinfo at 0x194c670>, 'blog_month_names': ...
path 	u'blog'
pattern 	u'blog/*'
req 	<Request "GET u'/blog'">
self 	<announcerplugin.subscribers.watchers.WatchSubscriber object at 0x18e8b30>
template 	'fullblog_view.html'

comment:3 Changed 8 years ago by Ryan J Ollos

Cc: Ryan J Ollos added; anonymous removed

comment:4 Changed 8 years ago by Grigoriy

I have the same problem. Do you know any solutions?

comment:5 Changed 8 years ago by Robert Corsaro

The problem is that this feature doesn't exist.

comment:6 Changed 7 years ago by Robert Corsaro

Status: newassigned

fullblog notifications plugin is implemented in trunk.

comment:7 Changed 7 years ago by Robert Corsaro

Priority: normallowest
Severity: majorminor

This feature is not generic enough to pick up any path. It will need to become more pluggable for this to work. Currently, it listens for wiki and ticket events only, so it will only work with ticket and wiki changes. I tested on trunk and there are no longer any errors with watching other paths (like /blog).

comment:8 Changed 5 years ago by Steffen Hoffmann

Keywords: API added
Owner: changed from Robert Corsaro to Steffen Hoffmann
Priority: lowestlow
Status: assignednew

This is a matter of providing code for additional event producers and subscribers. So far there is explicit demand only for

I suggest to provide patches, or better: bundle the support with each of these plugins. Thoughts?

comment:9 in reply to:  8 ; Changed 5 years ago by Ryan J Ollos

Cc: Odd Simon Simonsen added

Replying to hasienda:

I suggest to provide patches, or better: bundle the support with each of these plugins. Thoughts?

I think it makes sense to bundle the support with the individual plugins. We can do this for DiscussionPlugin since it is currently unmaintained, and Blackhex has offered it up for adoption. I've even pushed some patches recently for that plugin. For FullBlogPlugin, whether or not to include it in opt comes down to the preference of osimons.

comment:10 in reply to:  9 Changed 5 years ago by Steffen Hoffmann

Summary: Catch changes from other pluginsCatch changes from DiscussionPlugin

Replying to rjollos:

Replying to hasienda:

I suggest to provide patches, or better: bundle the support with each of these plugins. Thoughts?

I think it makes sense to bundle the support with the individual plugins.
...
For FullBlogPlugin, whether or not to include it in opt comes down to the preference of osimons.

His answer has been given in #9110. I'll have to look at it, but I trust osimons, so it seem that the request holds. Changing ticket summary accordingly.

comment:11 Changed 8 months ago by Ryan J Ollos

Owner: Steffen Hoffmann deleted

comment:12 Changed 4 months ago by Ryan J Ollos

Resolution: wontfix
Status: newclosed

See #12971.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.