Modify

Opened 9 years ago

Closed 11 months ago

#3536 closed enhancement (duplicate)

Generate TOC for a set of pages from a particular page

Reported by: anonymous Owned by:
Priority: normal Component: TocMacro
Severity: normal Keywords: Toc
Cc: Trac Release: 0.11

Description (last modified by Ryan J Ollos)

Is there any simple way to generate the TOC for a set of pages from another page? Right now I can generate a TOC for a set of pages as:

[[TOC(TracGuide, TracInstall, TracUpgrade, TracIni, ...)]]

So to show my custom TOC on every subpage, I have to insert it multiple times. Of course, if the TOC changes, I have to adjust it on all subpages, which is a whole lot of work! If the TOC could be generated from a particular page, all I had to do was to generate a page like this:

[TracGuide Trac Guide]
[TracInstall Installing Trac]
[TracUpgrade Upgrading Trac]
[TracIni Trac Ini]

The TOC macro should then be able to transform this page into a TOC.

[[TOC(MyTocPage)]]

Now, if the TOC changes, all I have to do is to adjust the MyTocPage and the new TOC will be applied automatically to every page that includes the macro.

What do you think about it?

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by anonymous

Now that I look at it, this is the same as #12197 that I just reported (with a patch), although the format is just a little different; the functionality asked for here would be [[TOC(indirect=MyTocPage)]] with the patch from #12197.

comment:2 Changed 3 years ago by Ryan J Ollos

Owner: Noah Kantrowitz deleted

comment:3 Changed 2 years ago by Ryan J Ollos

Description: modified (diff)

comment:4 Changed 11 months ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Closing as a duplicate of #12197.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.