Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#355 closed defect (fixed)

New blog post disappears when formatted

Reported by: anuradha.moturi@… Owned by: John Hampton
Priority: normal Component: TracBlogPlugin
Severity: normal Keywords:
Cc: Akshay Guleria Trac Release: 0.9


A new blog post disappears when I edit the post to add test formating like bolding words or adding bullets.The page exists otherwise though but doesnt appear in the blog posts anymore.

Attachments (0)

Change History (7)

comment:1 Changed 12 years ago by John Hampton

Status: newassigned

Can you please share your config?

  • what version of trac?
  • latest svn checkout of blog plugin?
  • value of [blog] section in trac.ini

Also, are you modifying the values of the "Tag under" box?

comment:2 Changed 12 years ago by anradha.moturi@…

The version of TRAC that I am using is Trac 0.9.4. The trac blog plugin that I am using is The following is the [blog] section in the trac.ini

date_format = %x %X
history_days = 365
post_size = 102400
page_format = %d-%m-%Y_%H.%M
new_blog_link = New Blog Post
first_week_day = MONDAY
default_tag = blog news events daily
mark_updated = true

No I am not modify the values of the "Tag under" text box.

comment:3 Changed 12 years ago by John Hampton

Resolution: fixed
Status: assignedclosed

(In [758]) * Fixed error in splitting multiple tags in the default_tag ini option. Problem was similar to #334. Closes #355

comment:4 Changed 12 years ago by John Hampton

give the latest update a try. I believe that this will fix the issue.

The issue was improper handling of multiple tags being specified in the default_tag field. I was expecting them to be separated by commas. With your configuration, because the values are separated by spaces, it was taking the whole line as one tag. When you updated the page, the Tags module properly split the tags, but the blog plugin was looking for pages that contained the whole line as a tag itself.

The only reason this actually worked partially was do to a related bug in the new post module. See #334 for more details.

I fixed it so that now whitespace or commas should be sufficient to separate tag values.

comment:5 Changed 12 years ago by anuradha.moturi@…

Resolution: fixed
Status: closedreopened

Thank you for helping me out.I have installed the latest version of tracblogplugin.On doing so


  • the new blog posts even edited are showing up fine

but there still seems to be a problem


  • all my previous posts have disappeared even those which were not edited

comment:6 Changed 12 years ago by John Hampton

Ahh, yes :) There are two ways to fix this:

1) simply "edit" each of the previous posts. A simple "edit this page" and then "submit changes" should be enough. If not, make sure that there are commas in between the tags.

2) Modify the DB manually. In the tags table, if you do:

select * from tags;

you'll probably see some entries where there are multiple tags per row for a given page. There should only be one tag per row, so use your SQL-foo to correct that.

solution 1 is easier, but it will probably have the side effect of showing all posts as "Updated"

solution 2 is obviously harder and probably more tedious, but it will save the post from being marked "Updated"

Give one of those a try and let me know how it goes. If that solves the issue, please close this ticket as fixed

comment:7 Changed 12 years ago by anuradha.moturi@…

Resolution: fixed
Status: reopenedclosed

Yea it works:) thank you .

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain John Hampton.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.