Modify

Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#3550 closed defect (fixed)

AttributeError: 'LocalTimezone' object has no attribute 'normalize'

Reported by: martin.haeger@… Owned by: John Hampton
Priority: normal Component: IrcLogsPlugin
Severity: normal Keywords: pytz
Cc: Trac Release: 0.11

Description

Getting an error "AttributeError: 'LocalTimezone' object has no attribute 'normalize'" when trying to access irclogs. I'm running pytz 2008c, Python 2.5 on Windows XP SP2. Is there any known incompatibilities with specific versions of pytz, or should this be considered a bug?

How to Reproduce

While doing a GET operation on /irclogs, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'day': '13', 'feed': None, 'feed_count': None, 'month': '08', 'year': 2008}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

System Information

Trac 0.11.1
Python 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]
setuptools 0.6c7
SQLite 3.3.4
pysqlite 2.3.2
Genshi 0.5
Pygments 0.10
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "c:\python25\lib\site-packages\Trac-0.11.1-py2.5.egg\trac\web\main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "c:\python25\lib\site-packages\Trac-0.11.1-py2.5.egg\trac\web\main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\irclogs\web_ui.py", line 352, in process_request
    req.tz)
  File "build\bdist.win32\egg\irclogs\web_ui.py", line 140, in _render_lines
    local_dt = tz.normalize(server_dt.astimezone(tz))
AttributeError: 'LocalTimezone' object has no attribute 'normalize'

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by martin.haeger@…

As mentioned in this conversation, the user trying to access the IRC logs must have set a timezone in preferences. This could also be done by setting the default timezone in trac.ini like this:

[trac]
default_timezone = Europe/Oslo

comment:2 Changed 9 years ago by Chris Hildebrandt

Even if you set a default time zone, the user can always overwrite it. If he does by using the given Country/City entries, there will be no problem. However, if he uses one of the GMT+/-hours entries, the problem will be back. Greetings, Chris

comment:3 Changed 8 years ago by anonymous

Resolution: fixed
Status: newclosed

fixed in parser_refactor branch. merging soon.

comment:4 Changed 7 years ago by Steffen Hoffmann

(In [10143]) TracFormsPlugin: Releasing version 0.3, pushing development to 0.4, closes #3445, #3550, #3741, #4759 and #8258, refs #3388 and #6993.

This is a major release requiring a Trac environment upgrade.

While the parser logic remains unchanged, there is a lot new supplementary funcionality to make TracForms behave more like the existing Trac core resources (ticket, wiki, attachment, ...).

This version performs a series of non-trivial db schema changes, that especially may leave traces of stale forms (i.e. recorded for wiki pages, that don't exist anymore). So please make sure to read the changelog, BACKUP your environment(s) before installing this version as usual and check the new db tables forms, forms_fields and forms_history after upgrading.

comment:5 in reply to:  4 Changed 7 years ago by Steffen Hoffmann

Replying to hasienda:

(In [10143]) TracFormsPlugin: Releasing version 0.3, pushing development to 0.4, closes #3445, #3550, #3741, #4759 and #8258, refs #3388 and #6993.

The reference was unintended and meant to point at #3550 instead. Sorry for the noise.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain John Hampton.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.