Modify

Opened 9 years ago

Closed 8 years ago

#3628 closed defect (fixed)

Topic subjects should disregard wiki page names

Reported by: kasper@… Owned by: Radek Bartoň
Priority: normal Component: DiscussionPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

If you post a topic which contains the name of a wiki page then the link to the topic is replaced by a link to the wiki page. This is very confusing to users and may require you to click the id on the topic list instead of the subject.

Here's an example (take note of the "DataCleaner 1.2 is out!" and "Report on DataCleaner development process" topics): http://www.eobjects.dk/trac/discussion/1

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by Radek Bartoň

Status: newassigned

That is intended behavior since topic name is parsed with wiki syntax interpreter. You can always use ! before any wiki name. Do you have any suggestion how to provide behavior you want but keep current behavior as default?

comment:2 Changed 9 years ago by kasper@…

I guess a configuration option to disable the wiki interpreter for subject fields would be the best solution then?

I wouldn't assume that my users are aware of the wiki syntax so I can't require them to use the ! symbol (although I will go and edit the existing posts now to fix my forum).

comment:3 Changed 9 years ago by Radek Bartoň

OK, then there will be an option to disable sublinks in topic display.

comment:4 Changed 9 years ago by kasper@…

Great that will suit everyone's needs :)

comment:5 Changed 8 years ago by anonymous

Resolution: fixed
Status: assignedclosed

Fixed in trunk with r5258. As soon as trunk will be tested enough, it will be merged to 0.11 branch.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Radek Bartoň.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.