Modify

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#3742 closed defect (fixed)

[Patch] First submit crashes

Reported by: didley@… Owned by: Steffen Hoffmann
Priority: normal Component: TracFormsPlugin
Severity: normal Keywords: submit error
Cc: Ryan J Ollos, Jan Beilicke Trac Release: 0.11

Description

Always when I use a new Form and use the submit button the first time the submit crashes with

'DBCursor' object has no attribute 'lastrowid'

The field operations works for example the input field is changed but not the query operations.

When I submit the form second time it works.

Attachments (1)

tracformsplugin.patch (487 bytes) - added by Justin R. Cutler 8 years ago.
Patch to fix 'DBCursor' object has no attribute 'lastrowid' error

Download all attachments as: .zip

Change History (16)

Changed 8 years ago by Justin R. Cutler

Attachment: tracformsplugin.patch added

Patch to fix 'DBCursor' object has no attribute 'lastrowid' error

comment:1 Changed 8 years ago by Justin R. Cutler

See attached patch for a fix that works for me. (I am using SQLite 3.5.9 and pysqlite 2.3.2 under Python 2.5.2.)

comment:2 Changed 8 years ago by Gunnar Thielebein

@jrcurtler

Thanks for the patch, seems to work with current trunk and 0.11.2

comment:3 Changed 8 years ago by anonymous

Cc: ryano@… added; anonymous removed

comment:4 Changed 8 years ago by Ryan J Ollos

Cc: Ryan J Ollos added; ryano@… removed

comment:5 Changed 7 years ago by Ryan J Ollos

Summary: First submit crashes[Patch] First submit crashes

comment:6 Changed 7 years ago by Steffen Hoffmann

Keywords: submit error added

Patch tested and fix confirmed, changeset prepared for commit here. Waiting for permission ...

comment:7 Changed 7 years ago by Steffen Hoffmann

Owner: changed from Rich Harkins to Steffen Hoffmann
Status: newassigned

Got permissions, so will apply this soon.

comment:8 Changed 7 years ago by Jan Beilicke

Cc: Jan Beilicke added

comment:9 Changed 6 years ago by Steffen Hoffmann

Resolution: fixed
Status: assignedclosed

(In [9925]) TracFormsPlugin: Fix error 'DBCursor' object has no attribute 'lastrowid', closes #3742.

Thanks to Justin R. Cutler for contributing this patch.

comment:10 Changed 6 years ago by anonymous

how to run the patch?thx

comment:11 in reply to:  10 Changed 6 years ago by Steffen Hoffmann

Replying to anonymous:

how to run the patch?thx

As it's reportedly committed in changeset [9925] checking out plugin sources at that or a later version will have it included.

See howto install a plugin or ask at the trac-users wiki:MailingList, if you're looking for such basic information on Trac plugins, please. The ticket system here is dedicated to plugin development. Thanks for taking care.

comment:12 Changed 6 years ago by Steffen Hoffmann

Reporting back on success, if that solves an issue you saw before, would be still appreciated.

comment:13 Changed 6 years ago by Steffen Hoffmann

I've to admit, that I was quite clueless before.

See #5667 how this is fixed very differently for TracForms > 0.3.1 now. Thanks to rblank for providing insightful explanations of the compatible native Trac db cursor, that we're using now.

comment:14 Changed 6 years ago by didley@…

This solve my problem as I reported 09/1808.

Many thanx

didley

comment:15 Changed 6 years ago by Steffen Hoffmann

Thanks for the feedback.

Nevertheless the final changeset tot #5667 is still pending due to an issue in the new db schema upgrade code. Would be nice, if you could check it after submission.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.