Opened 10 years ago

Closed 4 years ago

#3962 closed defect (wontfix)

MergeInfoEnhancer has error with merges from SVN 1.4.x

Reported by: smrobinson62@… Owned by: Emmanuel Blot
Priority: normal Component: RevtreePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11


I've installed Revtree 0.5.16


on both a test server and a production server running Trac 0.11.1


served by Apache httpd 2.2.9 on Windows. When I have MergeInfoEnhancer disabled, all is well. When I enable it on the test server running Subversion 1.5.3, which does have some branches/tags/merges from 1.4.x and recent branches/merges from 1.5.3, it works as advertised. However, when I enable MergeInfoEnhancer on the production server which has branches/tags/merges mostly from 1.4.x and recent merges using 1.5.3, I get the following errors depending in the time range I chose.

Error: No such node
No node RB1.3 at revision 3049

Error: No such node
No node RB1.3 at revision 3084

Error: No such node
No node tags/1.2.9 at revision 2181

No errors are recorded in Trac logs. I re-sync'd the Trac DBs "just in case".

The changesets in branch RB1.3 are not for branches/tags. However, changesets 3050 and 3085, the next ones, are for creating tags from the branch RB1.3. Changeset 2181 is for the removal of tag/1.2.9 (to clear out a mistake) but 2182 is the creation of tag/1.2.9 from branch RB1.3 again. So it sounds like changesets/revisions are 1 off somewhere in MergeInfoEnhancer. These nodes display just fine when MergeInfoEnhancer is disabled.

I tried using Revtree 0.6.0 from rev. 4024 with code changes suggested in another ticket, but then no merge info was displayed, even on the test server where it is displayed with 0.5.16. There is no error and the tree looks correct for trunk/branches/tags.

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by Emmanuel Blot

Resolution: wontfix
Status: newclosed

RevtreePlugin/MergeInfoEnhancer is for SVN 1.5, I really don't know what the repository looks like before it is upgraded to SVN 1.5 format (using svnadmin upgrade).

Define the revbase parameter of the [revtree] section to discard any revisions prior to the migration to SVN 1.5.

Closing as wontfix.

comment:2 Changed 10 years ago by smrobinson62@…

I have run "svnadmin upgrade" (I converted to 1.5.3 on 10/15/08 and ran upgrade both then and again today as a precaution) and I tried limiting the time period to the past two weeks and I still get the error. I tried 1 day (OK), then 2, 3, 4 and as soon as the time range includes a changeset with a 1.5 merge (a mergeinfo property) or a tag from a branch, I get the error.

The range does not have to be starting from today. I can specify a range from a period last week when there were no merges or tags and revtree works fine. But if a specify a range a bit further back, still post-1.5.3 conversion, that has such a revision, the error happens again.

When I disable mergeinfoenhancer all ranges work fine.

It seems that the revision it complains about is either one before a revision where a tag is created or one after a revision with a mergeinfo property change.

comment:3 Changed 10 years ago by Emmanuel Blot

Resolution: wontfix
Status: closedreopened

I think I've been able to reproduce such an issue today.

As a workaround, try the hidden "reset" command to clean up the saved parameters for the current user: append ?reset=1 to the URL, i.e. if the URL for the revtree is




This should reset the user session (revtree parameter only).

Let me know if it helps - it's still a workaround, not a real fix though.

comment:4 Changed 10 years ago by smrobinson62@…

No, resetting my revtree session attributes (nor completely deleting them) made no difference. However, updating to rev 4697 fixed it - tags now show up as small rounded rectangles next to the revision they were taken from in the branch.


The problem appears to have been with tags, not mergeinfo.

That being said, I still do not see any merges reflected in the revtree. Here's an example: changeset 3207 from branch RB1.3 was merged to trunk resulting in changeset 3208 (all these changesets/revisons are post-upgrade). You can see the mergeinfo property was updated to include 3207. However, even though 3207 shows up in the revtree under RB1.3 and 3208 appears under trunk, there is no box around 3207 and no line to 3208 (nor from 2845, 2857, 3079).

Changeset 3208
    10/30/2008 12:05:43 AM (5 days ago)
    * Property svn:mergeinfo
            old new
            1	 	/branches/RB1.3/CHRInstaller:2845,2857,3079
             	1	/branches/RB1.3:3207
             	2	/branches/RB1.3/CHRInstaller:2845,2857,3079,3207

Changeset 3207
    10/29/2008 11:53:37 PM (5 days ago)

comment:5 Changed 4 years ago by Emmanuel Blot

Resolution: wontfix
Status: reopenedclosed

I do not think SVN 1.4 support is relevant anymore.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.