Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4006 closed defect (fixed)

MergeInfoEnhancer missing SimpleContainer

Reported by: jp.stacey@… Owned by: Emmanuel Blot
Priority: normal Component: RevtreePlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

RevTree itself works brilliantly: thanks for that. It's really improved our ability to track subversion branches.

However, we're trying to get MergeInfoEnhancer to work, and running up against a number of problems (this is in revision 4024). If we just build the egg and drop it in (and enable it in the config, we get the following error:

NameError: global name 'SimpleContainer' is not defined

(how-to-reproduce below). It looks like SimpleContainer isn't imported by enhancer.py at all, but it does exist in MergeEnhancer.

If we then build an egg for MergeEnhancer and drop that in (and enable it), and also put in mergeinfoenhancer/enhancer.py:

from mergeenhancer.enhancer import SimpleContainer

then we get a different error, which doesn't give us a stacktrace, saying

No node REL-1.1-webform at revision 1321

Below is the standard Trac how-to-reproduce for the first error.

How to Reproduce

While doing a GET operation on /revtree, Trac issued an internal error.

Request parameters:

{'author': u'',
 'branch': u'',
 'limits': u'limrev',
 'period': u'31',
 'revmax': u'1336',
 'revmin': u'1290',
 'style': u'compact'}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3

System Information

Trac 0.11.1
Python 2.5.2 (r252:60911, Sep 29 2008, 21:31:01)
[GCC 4.3.2]
setuptools 0.6c8
psycopg2 2.0.7
Genshi 0.5
mod_python 3.3.1
Pygments 0.10
Subversion 1.5.4 (r33841)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/revtree/web_ui.py", line 246, in process_request
    return self._process_revtree(req)
  File "build/bdist.linux-i686/egg/revtree/web_ui.py", line 335, in _process_revtree
    style=revstore['style'])
  File "build/bdist.linux-i686/egg/revtree/svgview.py", line 981, in create
    self.repos, self))
  File "build/bdist.linux-i686/egg/mergeinfoenhancer/enhancer.py", line 158, in create
    return MergeInfoEnhancer(env, req, repos, svgrevtree)
  File "build/bdist.linux-i686/egg/mergeinfoenhancer/enhancer.py", line 36, in __init__
    enhancer = SimpleContainer()
NameError: global name 'SimpleContainer' is not defined

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by Emmanuel Blot

Status: newassigned

I will have a look at it, 0.6.x is still in early development stage, you may want to checkout the latest 0.5.x version of the plugin.

comment:2 Changed 8 years ago by Emmanuel Blot

Resolution: fixed
Status: assignedclosed

fixed: (In [4696]) Fixes #4006. The reported bug is fixed, however the merge graph is not yet fully valid.

comment:3 Changed 8 years ago by Emmanuel Blot

Duplicate of #3639

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.