Modify

Opened 8 years ago

Closed 5 years ago

#4033 closed enhancement (duplicate)

Let Login Module disable the default Trac login module

Reported by: Alex Baeza Owned by: Steffen Hoffmann
Priority: low Component: AccountManagerPlugin
Severity: trivial Keywords: login dependency disable
Cc: Trac Release: 0.11

Description

It would be very nice if when I enable LoginModule from the WebAdmin all necessary trac.ini modifications were made for me.

Currently when I enable the LoginModule from WebAdmin it will enable this feature in the trac.ini, but it does not disable the default Trac login module. Ideally it would do this for me. This would be an especially helpful addition to this wonderful hack.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by Steffen Hoffmann

Keywords: needinfo added
Owner: changed from Matt Good to Steffen Hoffmann

I think it should be quite easy to detect, if the default Trac login module is enabled (explicitely or implicitely) by checking current configuration on startup. To actively disable the module is probably a different thing. At least I've not seen such cross-component action before.

Any hints, where to look for a reference? Patch welcome.

comment:2 Changed 5 years ago by Steffen Hoffmann

Keywords: login dependency disable added; needinfo removed
Resolution: duplicate
Status: newclosed

Sorry, that I didn't spot this much earlier, but this is essentially a duplicate of #3459. Maybe, because I liked the summary of this one much better. Thanks for taking care anyway.

Hint: Only recently this topic has been worked on. See [11943] for the suggested fix.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.