Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#4258 closed defect (fixed)

easy_install failed

Reported by: mat_the_green@… Owned by: hasienda
Priority: low Component: BreadCrumbsNavPlugin
Severity: normal Keywords: setuptools
Cc: rjollos Trac Release: 0.11

Description (last modified by rjollos)

I tried to install and got the following:

$ sudo easy_install
Doing subversion checkout from to /tmp/easy_install-YwMmp5/0.11
Processing 0.11
Running -q bdist_egg --dist-dir /tmp/easy_install-YwMmp5/0.11/egg-dist-tmp-gj_GFi
Traceback (most recent call last):
  File "/usr/bin/easy_install", line 8, in <module>
    load_entry_point('setuptools==0.6c8', 'console_scripts', 'easy_install')()
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 1671, in main
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 1659, in with_ei_usage
    return f()
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 1675, in <lambda>
    distclass=DistributionWithoutHelpCommands, **kw
  File "/usr/lib/python2.5/distutils/", line 151, in setup
  File "/usr/lib/python2.5/distutils/", line 974, in run_commands
  File "/usr/lib/python2.5/distutils/", line 994, in run_command
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 211, in run
    self.easy_install(spec, not self.no_deps)
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 422, in easy_install
    return self.install_item(None, download, tmpdir, deps, True)
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 476, in install_item
    dists = self.install_eggs(spec, download, tmpdir)
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 655, in install_eggs
    return self.build_and_install(setup_script, setup_base)
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 930, in build_and_install
    self.run_setup(setup_script, setup_base, args)
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 919, in run_setup
    run_setup(setup_script, args)
  File "/usr/lib/python2.5/site-packages/setuptools/", line 27, in run_setup
    lambda: execfile(
  File "/usr/lib/python2.5/site-packages/setuptools/", line 63, in run
    return func()
  File "/usr/lib/python2.5/site-packages/setuptools/", line 29, in <lambda>
    {'__file__':setup_script, '__name__':'__main__'}
  File "", line 48, in <module>
  File "/usr/lib/python2.5/distutils/", line 151, in setup
  File "/usr/lib/python2.5/distutils/", line 974, in run_commands
  File "/usr/lib/python2.5/distutils/", line 994, in run_command
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 167, in run
  File "/usr/lib/python2.5/distutils/", line 333, in run_command
  File "/usr/lib/python2.5/distutils/", line 994, in run_command
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 171, in run
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 252, in find_sources
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 306, in run
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 333, in add_defaults
    rcfiles = list(walk_revctrl())
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 45, in walk_revctrl
    for item in ep.load()(dirname):
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 52, in _default_revctrl
    for path in finder(dirname,path):
  File "/usr/lib/python2.5/site-packages/setuptools/command/", line 98, in entries_finder
    log.warn("unrecognized .svn/entries format in %s", dirname)
NameError: global name 'log' is not defined

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by hasienda

  • Keywords setuptools added

I think I've seen this before.

You need to upgrade setuptools to 0.6c9 or beyond first. This should remove the error.

comment:2 Changed 5 years ago by hasienda

  • Cc rjollos added; anonymous removed
  • Keywords needinfo added
  • Priority changed from normal to low

Please check the solution in previous comment.

I drop the priority for now, because I see no way to give further assistance and expect this issue to be resolved by now anyway. I'll close this ticket after a reasonable time without feedback, say 6 months, but user comments and independent, more current test reports would help to clear this case earlier.

comment:3 Changed 5 years ago by hasienda

  • Owner changed from ixokai to hasienda

forgot to reflect new maintainer status

comment:4 follow-up: Changed 5 years ago by rjollos

  • Description modified (diff)

comment:5 in reply to: ↑ 4 Changed 5 years ago by hasienda

Replying to rjollos:

Thanks for the greatly improved readability of the traceback.

comment:6 Changed 5 years ago by mat_the_green@…

  • Resolution set to fixed
  • Status changed from new to closed

I have tried again and it worked, my python-setuptools is currently 0.6c8-0ubuntu2.

comment:7 Changed 5 years ago by hasienda

  • Keywords needinfo removed

Thank you for repeated testing and positive feedback.

As a side-note, I wasn't able to install Trac 0.12 or later even with the stock Debian version of python-setuptools (0.6.14-4), but with setuptools-0.6c11 installed from source I succeeded. Just an idea, if you experience similar problems once again.

Add Comment

Modify Ticket

as closed The owner will remain hasienda.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.