Modify

Opened 8 years ago

Closed 6 years ago

#4292 closed defect (duplicate)

Re-assigning the TimingAndEstimationPlugin menu as submenu does not work

Reported by: izzy Owned by: Catalin BALAN
Priority: normal Component: MenusPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

The TimingAndEstimationPlugin registers itself as "Billing" to the mainnav, using the label "Management". The following works perfect: Billing.label = Whatever. However, trying to move this menu item to a submenu fails:

tools.parent = top
tools.label = Tools
worklog.parent = Tools
worklog.hide_if_disabled = 1
Billing.label = Billing
Billing.parent = tools
...

This makes a new menu item show up labeled "Tools" (as expected). Also, the "Work Log" menu is moved into the new "Tools" menu. TimingAndEstimationPlugin shows up as "Billing" - but not in the "Tools" menu: It kept its Place at top level.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Thomas Moschny

Resolution: duplicate
Status: newclosed

Duplicate of #7498.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Catalin BALAN.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.