Modify

Opened 8 years ago

Closed 7 years ago

#4737 closed defect (worksforme)

searching with the sensitive tickets plugin in version 0.11 creates a

Reported by: anonymous Owned by: obs
Priority: normal Component: SensitiveTicketsPlugin
Severity: normal Keywords:
Cc: Jeff Hammel, m.a.swertz@… Trac Release: 0.11

Description

Trac detected an internal error:

RuntimeError: maximum recursion depth exceeded

see attached for traceback (only the first part is included) The error directly points to sensitivetickets

Attachments (1)

tracbug.txt (16.6 KB) - added by myrond@… 8 years ago.
traceback for sensitive tickets bug in if 'SENSITIVE_VIEW' not in perm

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by myrond@…

Attachment: tracbug.txt added

traceback for sensitive tickets bug in if 'SENSITIVE_VIEW' not in perm

comment:1 Changed 8 years ago by Jeff Hammel

Cc: Jeff Hammel added; anonymous removed

comment:2 Changed 8 years ago by Jeff Hammel

this is hard to debug with so little information. what were you doing to get this error? did you have the SENSITIVE_VIEW permission? verbose reproduction steps needed

comment:3 Changed 7 years ago by obs

Owner: changed from Sebastian Benthall to obs

comment:4 Changed 7 years ago by anonymous

Cc: m.a.swertz@… added

I have the same problem, caused by the combined use of SensitiveTicketsPlugin with PrivateTicketsPlugin. It seems the PrivateTicketsPolicy and SensitiveTicketsPolicy recursively call each other.

Why both?

  • I want to hide sensitive tickets in anonymous view and
  • limit the visibility of these tickets to particular groups in authenticated view

A solution seems to merge the two plugins but that is not trivial (for a non python programmer at least).

comment:5 Changed 7 years ago by obs

Resolution: worksforme
Status: newclosed

Cannot replicate issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain obs.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.