Modify

Opened 9 years ago

Last modified 4 years ago

#4876 assigned defect

Can remove expanded group, but cannot remove expanded path

Reported by: Leon Owned by: Ryan J Ollos
Priority: normal Component: SvnAuthzAdminPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

The file "steps_to_reproduce_bug_report.txt" details the steps that I used to reproduce the ticket

Screenshots are attached as well, to help in conveying the steps.

Suggestions on Fix / Resolution:

  1. Display an error message informing a user that it is not possible to remove an expanded path / can only remove collapsed list items
  2. Enhance software so it can successfully remove a path if the path is expanded

Note: I have tested this on a trac 0.10 installation but believe it may affect a 0.11 Trac install too. Note: Since there is NO data destruction occuring, I have left the severity as normal.

Attachments (2)

steps_to_reproduce_bug_report.txt (1.6 KB) - added by Leon 9 years ago.
screenshots.zip (458.1 KB) - added by Leon 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by Leon

Changed 9 years ago by Leon

Attachment: screenshots.zip added

comment:1 Changed 8 years ago by rupert thurner

Resolution: worksforme
Status: newclosed

can't reproduce with 0.11 version.

comment:2 Changed 8 years ago by rupert thurner

Resolution: worksformefixed

(In [6344]) return something iteratable to avoid none check, fix #4876.

comment:3 Changed 8 years ago by rupert thurner

Resolution: fixed
Status: closedreopened

this fix seems not good ...

comment:4 Changed 4 years ago by Ryan J Ollos

Owner: changed from Kis Gergely to Ryan J Ollos
Status: reopenedassigned

Modify Ticket

Change Properties
Set your email in Preferences
Action
as assigned The owner will remain Ryan J Ollos.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.