Modify

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#500 closed defect (fixed)

Support content syndication using the RSS (Really Simple Syndication) XML format from Discussoins

Reported by: dgreen@… Owned by: Radek Bartoň
Priority: normal Component: DiscussionPlugin
Severity: normal Keywords: RSS
Cc: Trac Release: 0.9

Description

Please consider supporting RSS feed from discussion plugin.

Attachments (1)

bug500log.txt (44.8 KB) - added by dgreen@… 11 years ago.
requested log file

Download all attachments as: .zip

Change History (14)

comment:1 Changed 11 years ago by Radek Bartoň

Status: newassigned

Discussion events are be recorded to Trac's timeline which has RSS format too. Do you mean that feature or something else?

comment:2 Changed 11 years ago by dgreen@…

I do see discussions posted to timeline. I do have "discussions=on" in RSS feed but the discussions (neither first post in topic or successive posts) do not show in the feed.

comment:3 Changed 11 years ago by Radek Bartoň

I testested it recently but there could be something broken since. I'll take a look again.

comment:4 Changed 11 years ago by Radek Bartoň

I've tested it and it seems that it works.

Using:

http://localhost:8000/Test/timeline?discussion=on&max=50&daysback=90&format=rss

I got:

<?xml version="1.0"?>
<rss version="2.0">
 <channel>
   <title>Test: Timeline</title>
  <link>http://localhost:8000/Test/timeline</link>
  <description>Trac Timeline</description>
  <language>en-us</language>
  <generator>Trac v0.9.6</generator>
   <image>
    <title>Test</title>
    <url>http://localhost:8000/Test/chrome/common/trac_banner.png</url>
    <link>http://localhost:8000/Test/timeline</link>
   </image>
   <item>
    <title>New reply on Test created by blackhex</title>
    <pubDate>Wed, 12 Jul 2006 13:55:53 GMT</pubDate>
    <link>http://localhost:8000/Test/discussion/1/1/1#1</link>
    <description>&lt;p&gt;
Test
&lt;/p&gt;
</description>
   </item>
   <item>
    <title>New topic on Test created by blackhex</title>
    <pubDate>Wed, 12 Jul 2006 13:55:44 GMT</pubDate>
    <link>http://localhost:8000/Test/discussion/1/1</link>
    <description>&lt;p&gt;
Test
&lt;/p&gt;
</description>
   </item>
   <item>
    <title>New forum Test created by blackhex</title>
    <pubDate>Wed, 12 Jul 2006 13:55:37 GMT</pubDate>
    <link>http://localhost:8000/Test/discussion/1</link>
    <description>&lt;p&gt;
Testing Forum - Testing Forum description
&lt;/p&gt;
</description>
   </item>
 </channel>
</rss>

If are you getting something else please post more info about your sytem Trac version and so one...

comment:5 Changed 11 years ago by anonymous

Using that URL (modified for my server) strangely gives an RSS feed for the other components (Wiki, Changeset, Ticket, Milestones, etc. but no discussion.

Trac 0.9.5 Just downloaded Discussion Plug-in from Trac Hacks Using SQLITE3

comment:6 Changed 11 years ago by Radek Bartoň

In changeset 1038 I've added some debug outputs for timeline module. Could you please test it again with lastest changeset and then post relevant parts of debug log? Information about your web server where you run your Trac would be usefull too. Thank you.

Changed 11 years ago by dgreen@…

Attachment: bug500log.txt added

requested log file

comment:7 Changed 11 years ago by dgreen@…

I used changeset 1048 which I believe, for the DiscussionPlugIn is the same thing.

Added another reply to an existing discussion and then a new topic within existing forum.

at 00:00:26 I hit it with (domain of server removed)

http://eceserv4.../projects/oumgt/timeline?discussion=on&max=50&daysback=90&format=rss

I see errors related to not having webadmin.web.ui loaded. Is that a dependency I missed? I thought it was optional.

bug500log.txt attached.

Using apache on/from SUSE 10.1, (Apache/2.2.0 (Linux/SUSE))

using an include to get:

<Location /projects/oumgt>

SetHandler mod_python PythonHandler trac.web.modpython_frontend PythonOption TracEnv /srv/trac/oumgt PythonOption TracUriRoot /projects/oumgt SetEnv PYTHON_EGG_CACHE /srv/trac/oumgt/egg_cache

</Location>

<Location "/projects/oumgt/login">

AuthType Basic AuthName "oumgt" AuthUserFile "/etc/svn-auth-file" Require valid-user

</Location>

comment:8 Changed 11 years ago by Radek Bartoň

If you don't have WebAdminPlugin installed don't use admin module of Discussion plugin (put tracdiscussion.admin.discussionwebadmin = disable) in [components] section in trac.ini). But I don't think that this is the problem with missing items in timeline. Post here please lines from your log starting with "Trac[timeline]". This could tell me more.

comment:9 Changed 11 years ago by Radek Bartoň

Sorry, I didn't notice attachment.

comment:10 Changed 11 years ago by Radek Bartoň

I studied log output. There is nothing wrong with timeline events generation and them should be corectly returned to Trac. Maybe error when loading non-existing module from WebAdminPlugin prevents Trac from display them so I was maybe wrong to say that this eror is not relevant. Please append or change

[components]
tracdiscussion.admin.discussionwebadmin = disable

line in your trac.ini. If this doesn't help error has to be somewhere between Trac and RSS page output.

comment:11 Changed 11 years ago by dgreen@…

OK, anonymous did not have DISCUSSION_VIEW which was keeping the feed from being accessible (even when the feed request was supplying credentials). Giving anonymous DISCUSSION_VIEW gets feed to work but has the unfortunate side effect that I wanted to avoid of having folks be able to post without authentication.

Perhaps that would be an enhancement request to separate DISCUSSION_VIEW and DISCUSSION_POST/REPLY/PARTICIPATE (or whatever).

Additionally, FWIW, even disabling doing the

[components]
tracdiscussion.admin.discussionwebadmin = disable

Did not eliminate the message about webadmin.web.ui

So as it stands, I have to choose between anonymous discussion posters (no issue with viewers) and RSS feed.

Thanks for help. I think the behavior is by design (although that is your call) so probably this ticket could close and either one or two other tickets could be started (enhancement for splitting permissions VIEW from Participate, minor defect where discussionadmin tries to initialize even when disabled although that may be "by design" or within Trac).

comment:12 Changed 11 years ago by Radek Bartoň

Resolution: invalid
Status: assignedclosed

Defined permission is heritage from old Athomas's concept. They could be changed as you suggested. Anyway thank you for your clarification and interest.

comment:13 Changed 10 years ago by Matteo Merli

Resolution: invalidfixed

(In [2020]) Return the correct encoding in the DocumentProvider. Fixes #500

Modify Ticket

Action
as closed The owner will remain Radek Bartoň.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.