Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#5273 closed defect (fixed)

SyntaxErrors (for python <2.5) in PyGit.py and git_fs.py in revision 5846

Reported by: anonymous Owned by: Herbert Valerio Riedel
Priority: normal Component: GitPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Syntax Errors:

source:/gitplugin/0.11/tracext/git/git_fs.py#5846#L361

source:/gitplugin/0.11/tracext/git/PyGIT.py#5846#L361

# python -V
Python 2.4.3

# svn update
At revision 5846.

# python tracext/git/git_fs.py 
  File "tracext/git/git_fs.py", line 361
    yield (self.path, rev, Changeset.EDIT if not is_last else Changeset.ADD)
                                           ^
SyntaxError: invalid syntax

# python tracext/git/PyGIT.py 
  File "tracext/git/PyGIT.py", line 89
    with self.__lock:
            ^
SyntaxError: invalid syntax

Attachments (2)

trac-gitplugin-fix-python-2.4.patch (10.4 KB) - added by Haw Loeung 8 years ago.
Patch for Python 2.4. Applies cleanly against r6157
trac-gitplugin-fix-python-2.4.2.patch (10.4 KB) - added by Haw Loeung 8 years ago.
Patch for Python 2.4. Applies cleanly against r6157

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by Jeremy Ross

It looks like python 2.5 is required for the more recent 0.11 versions

comment:2 Changed 8 years ago by anonymous

Is it possible to do for 2.4? I am using RedHat ?

Changed 8 years ago by Haw Loeung

Patch for Python 2.4. Applies cleanly against r6157

Changed 8 years ago by Haw Loeung

Patch for Python 2.4. Applies cleanly against r6157

comment:3 Changed 8 years ago by anonymous

The patches are empty.

comment:4 Changed 8 years ago by rnavarro@…

Haw,

Could you please repost the patches?

comment:5 in reply to:  3 ; Changed 8 years ago by roadrunner

Owner: changed from Herbert Valerio Riedel to roadrunner
Status: newassigned

Replying to anonymous:

The patches are empty.

No they aren't - it's just trac's display of the attachment that's broken. Click on the "Original Format" link at the bottom of the page to download the patch and you'll see that they are complete.

comment:6 Changed 8 years ago by roadrunner

Owner: changed from roadrunner to Herbert Valerio Riedel
Status: assignednew

(oops, didn't mean to change the owner)

comment:7 Changed 7 years ago by anonymous

Summary: SyntaxErrors in PyGit.py and git_fs.py in revision 5846SyntaxErrors (for python <2.5) in PyGit.py and git_fs.py in revision 5846

comment:8 in reply to:  5 Changed 7 years ago by anonymous

Replying to roadrunner:

Replying to anonymous:

The patches are empty.

No they aren't - it's just trac's display of the attachment that's broken. Click on the "Original Format" link at the bottom of the page to download the patch and you'll see that they are complete.

actually the problem is, that the patch contains binary data, because .pyc files were diffed:

diff -Naurp tmp/gitplugin/0.11/tracext/__init__.pyc gitplugin/0.11/tracext/__init__.pyc
--- tmp/gitplugin/0.11/tracext/__init__.pyc     1970-01-01 10:00:00.000000000 +1000
+++ gitplugin/0.11/tracext/__init__.pyc 2009-07-06 15:15:16.000000000 +1000

comment:9 Changed 7 years ago by Herbert Valerio Riedel

Resolution: fixed
Status: newclosed

(In [7752]) branched off python 2.4 backport of 0.11 using attachment:trac-git-plugin-python2.4.patch:ticket:6402

closes #6402 closes #5273 closes #3411 closes #5310

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Herbert Valerio Riedel.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.