Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5414 closed defect (fixed)

redirectfrom rooting incorrect

Reported by: Mark Potter Owned by: Martin Scharrer
Priority: normal Component: ServerSideRedirectPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Scenario:

  • Trac installed under Apache, accesable under http://host/trac.
  • There exists a wiki page SourcePage with a simple redirect of [[redirect(wiki:TargetPage)]]

After the redirection takes place to TargetPage:

  • With ServerSideRedirectPlugin enabled and TracRedirect disabled I am currently getting a URL of http://host/trac/wiki/TargetPage?redirectedfrom=/wiki/SourcePage
  • With ServerSideRedirectPlugin disabled and TracRedirect enabled I am currently getting a URL of http://host/trac/wiki/TargetPage?redirectedfrom=SourcePage with "Redirected from SourcePage" link on the page which correctly takes one back to http://host/trac/wiki/SourcePage.
  • With both ServerSideRedirectPlugin and TracRedirect enabled I am currently getting a URL of http://host/trac/wiki/TargetPage?redirectedfrom=/wiki/SourcePage; however with a "Redirected from /wiki/SourcePage" link on the page which incorrectly takes one to http://host/trac/wiki/wiki/SourcePage

I assume this issue is caused by my Trac installation not being rooted at http://host/ but at http://host/trac/.

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by Martin Scharrer

Resolution: fixed
Status: newclosed

Fixed in [6801]: Removed the /wiki/ from redirectedfrom.

comment:2 Changed 8 years ago by Martin Scharrer

Please use revision [6807] or later, which fixes some minor related problems.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Martin Scharrer.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.