Opened 9 years ago

Closed 9 years ago

#5500 closed defect (fixed)

Can't figure out how to enable macro

Reported by: Jonathan Turkanis Owned by: Simon Smithson
Priority: normal Component: RssEmbedMacro
Severity: normal Keywords:
Cc: Trac Release: 0.11


I've installed RssEmbed but when I try to use it I get "No macro or processor named 'RssEmbed' found"

I don't see any entry for it on the Admin Plugins page, and am not sure what to enter in trac.ini to enable the macro. I've tried all of the following, for fun:

rssembed.* = enabled
RssEmbed.* = enabled
tracrssembed.* = enabled
TracRssEmbed.* = enabled
rssembedmacro.* = enabled
RssEmbedMacro.* = enabled
tracrssembedmacro.* = enabled
TracRssEmbedMacro.* = enabled

I've also copied the egg to my Trac plugins directory as well as to the python site-packages directory, with no success.

Any help would be greatly appreciated.

Attachments (1)

rssembed-screenshot-2009-07-11.png (10.2 KB) - added by Jonathan Turkanis 9 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by Simon Smithson

I need a bit more information before I can tell you what is wrong. A good start would be to check the log for the project and see if there are any error messages in there. I would bet the module is not loading because feed parser is not installed.

On a ubuntu box the command to install is

sudo apt-get install python-feedparser

The correct line for trac.ini is

rssembed.macro.rssembedmacro = enabled

comment:2 Changed 9 years ago by Jonathan Turkanis

Thanks for your quick response!

Looking at my logs I found some messages like this:

Jul 12 04:03:52 xxxxx Trac[loader] ERROR: Skipping "rssembed.macro = \
    rssembed.macro": (can't import "ImportError: No module named feedparser")

I have made these changes:

  1. Entered the correct line in trac.ini
  2. Set the log level to DEBUG
  3. Installed this package:

When I load a wiki page that uses the RssEmbed macro, I get the error shown in the attached screenshot, but no log entries.

Changed 9 years ago by Jonathan Turkanis

comment:3 Changed 9 years ago by Simon Smithson

Sorry it took me so long to get to this, I'm not entirely sure what is going on here but could you send me a copy of the log from a fresh start up.

What version of python are you using? Did you compile the egg with the same version?

I am going to assk a silly question but did you follow the instructions at for installing a plugin for a single project?

Have you tried all the trouble shooting steps on that page?

comment:4 Changed 9 years ago by Jonathan Turkanis

Resolution: fixed
Status: newclosed

I am closing this ticket. Apparently, the initial problem was the missing python library, as you guessed. When I installed this library, I also pasted the code from your comment above

rssembed.macro.rssembedmacro = enabled 

into my trac.ini. But part of the code got cut off, so I actually ended up disabling the macro at the same time I instaled the library.

Thanks for your help.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Simon Smithson.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.