Modify

Opened 8 years ago

Closed 8 years ago

#5910 closed defect (duplicate)

Error with entries without author in timeline

Reported by: imcybot@… Owned by: Noah Kantrowitz
Priority: normal Component: HackergotchiPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Bitten inserts entries into the timeline that have no author, causing the HackergotchiPlugin to crash the timeline view.

This fixed it for me:

--- old/web_ui.py
+++ new/web_ui.py
@@ -38,6 +38,8 @@
                 closure_state[0] += 1
                 
                 # Extract the user information
+                if data['events'][n]['author'] is None:
+                    return stream
                 author = data['events'][n]['author'].strip()
                 user_info = cache.get(author)
                 if user_info is not None:

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by imcybot@…

Resolution: duplicate
Status: newclosed

Just noticed that this is a duplicate of #4336

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.