Modify

Opened 7 years ago

Closed 3 months ago

Last modified 3 months ago

#5963 closed defect (fixed)

doxygentrac cannot cope with subdirized doxygen documentation

Reported by: anonymous Owned by: Committo-Ergo-Sum
Priority: normal Component: DoxygenPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

My doxygen uses the CREATE_SUBDIRS feature to be able to have the amount of files in a manageable size. Additionally I use in my setup prefixes for the project where the docs reside, as such I have some svn/html prefix and a complete url to the docs looks like:

domain.com/doxygen/svn/html/d9/d3f/structfool_1_1bar.html

however on the tabs bar the annotated.html that is my entry point is visible via domain.com/doxygen/ (because its configured for the default project svn/html). As such clicking there on the link to classes.html it links to domain.com/doxygen/classes.html which it correctly redirects to the default projects domain.com/doxygen/svn/html/classes.html

Doing now the same for actual class documentation means I click on link to domain.com/doxygen/d9/d3f/structfool_1_1bar.html which should insert svn/html but does not do so. Looking at doxygentrac.py it seems the problem here is this line:

doc, file = segments[:-1], segments and segments[-1]

which does not take into account that there can be a subdirized documentation and treats just the one after the last / as the documentation file, and thinks the remaining d9/d3f is a project prefix like svn/html and leaves it as-is.

The easiest would probably be a config option to tell doxygentrac to use more than the last one for subdirized projects (however be aware of that it currently works as intended with the entry point files like classes.html that are not subdirized!)

Attachments (0)

Change History (3)

comment:1 Changed 17 months ago by rjollos

  • Description modified (diff)

comment:2 Changed 3 months ago by Committo-Ergo-Sum

  • Resolution set to fixed
  • Status changed from new to closed

In 15361:

DoxygenPlugin: add group write access to the entries created by Doxygen via this plugin, to allow manual configuration too.

And confirmation that r15360 fixes #5963.

comment:3 Changed 3 months ago by rjollos

  • Owner changed from cboos to Committo-Ergo-Sum

Add Comment

Modify Ticket

Action
as closed The owner will remain Committo-Ergo-Sum.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.