Modify

Opened 8 years ago

Closed 5 years ago

#6014 closed defect (worksforme)

"forgot password" delivers non-functional passwords

Reported by: anonymous Owned by: Steffen Hoffmann
Priority: normal Component: AccountManagerPlugin
Severity: major Keywords: needinfo password reset
Cc: Trac Release: 0.11

Description

forgot password is not working after click on forgot password link , we get new password but this new password is not working

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by Steffen Hoffmann

Cc: John Hampton added; anonymous removed
Keywords: needinfo password reset added
Summary: forgot password is not working"forgot password" delivers non-functional passwords

Update to recent version and provide more information regarding your environment and setup, please.

comment:2 Changed 7 years ago by Steffen Hoffmann

Owner: changed from Matt Good to Steffen Hoffmann
Priority: highnormal

I can't reproduce with current trunk version and Trac 0.12 right now.

Looks like a local installation/configuration issue and I've no idea about the root cause. So hereby I set a timeout for responses to clarify open questions by the reporter to the end of this year taking the long time of virtually non- existing support into account. Furthermore I decrease priority and suspend any further actions until then.

comment:3 Changed 6 years ago by Steffen Hoffmann

Resolution: worksforme
Status: newclosed

I've further tested this functionality while developing a different concept for #816.

There are no more complaints for months, if not years now, so I'll close this accordingly.

comment:4 Changed 6 years ago by sk_lau@…

Resolution: worksforme
Status: closedreopened

I'm using SECURECI which integrating Trac (0.11.5) with TracAccountManager 0.2.1dev-r5837. I am experiencing the same issue that the auto generated new password is not working. After submitted username and the new password, the login page keeps waiting for response for an hour. I can always reproduce the situation by

  1. before login, click Forgot your password? in the top menu
  2. enter user name and email
  3. obtained a new password in email
  4. go to login page and key in new username/password
  5. keep loading

Is there any idea? Thanks.

comment:5 in reply to:  4 ; Changed 6 years ago by Steffen Hoffmann

Cc: anonymous added; John Hampton removed

Replying to sk_lau@ymail.com:

I'm using SECURECI which integrating Trac (0.11.5) with TracAccountManager 0.2.1dev-r5837. I am experiencing the same issue that the auto generated new password is not working. After submitted username and the new password, the login page keeps waiting for response for an hour. I can always reproduce the situation by
1) before login, click Forgot your password? in the top menu
2) enter user name and email
3) obtained a new password in email
4) go to login page and key in new username/password
5) keep loading
Is there any idea? Thanks.

Apart from better formatting as done here? No, I fear not much. <sarcasm full-stop>

If I understand correctly, you're reopending this development ticket for reasoning about a 29 months old version? After we've released acct_mgr-0.3 about 4 months ago plus 2 really quite important maintenance releases for 0.11 branch? If that's right, please note, there's absolutely nothing to worry about acct_mgr-0.2.1dev anymore.

Get trunk, or at least acct_mgr-0.3.2 before going on. If you can't follow-up with more updated information, I'll close this ticket again very soon, sorry.

comment:6 in reply to:  5 Changed 5 years ago by Steffen Hoffmann

Resolution: worksforme
Status: reopenedclosed

Replying to hasienda:

Replying to sk_lau@ymail.com:

I'm using SECURECI which integrating Trac (0.11.5) with TracAccountManager 0.2.1dev-r5837.

...

Is there any idea? Thanks.

Get trunk, or at least acct_mgr-0.3.2 before going on. If you can't follow-up with more updated information, I'll close this ticket again very soon, sorry.

It looks reasonable to shut this down now, because the report most likely doesn't apply to any of the more recent revision of AcctMgr - for many months now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.