Modify

Opened 7 years ago

Closed 4 weeks ago

#6058 closed defect (worksforme)

[Patch] use to_unicode to avoid errors if svn files use different encoding

Reported by: anonymous Owned by: rjollos
Priority: normal Component: IncludeSourcePartialPlugin
Severity: normal Keywords:
Cc: massimo Trac Release: 0.11

Description

It's easy to commit a text file into svn and then import it with this plugin which breaks rendering the wiki page.

Attachments (1)

add_to_unicode.diff (1.5 KB) - added by anonymous 7 years ago.
add to_unicode

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by anonymous

add to_unicode

comment:1 Changed 7 years ago by anonymous

  • Summary changed from use to_unicode to avoid errors if svn files are broken to [Patch] use to_unicode to avoid errors if svn files are broken

comment:2 Changed 7 years ago by anonymous

  • Summary changed from [Patch] use to_unicode to avoid errors if svn files are broken to [Patch] use to_unicode to avoid errors if svn files use different encoding

comment:3 Changed 4 weeks ago by rjollos

  • Cc massimo added
  • Owner changed from chrisheller to rjollos
  • Status changed from new to accepted

comment:4 Changed 4 weeks ago by rjollos

  • Resolution set to worksforme
  • Status changed from accepted to closed

I can't reproduce with Trac 1.0-stable.

  1. Created a file with utf-8 encoded content:
    >>> with open('encoded', 'w') as f:
    ...     f.write(u"łÿö".encode('utf-8'))
    
    $file -I encoded 
    encoded: text/plain; charset=utf-8
    
  2. Added to SVN with svn:mime-type text/plain.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.