Modify

Opened 8 years ago

Closed 4 years ago

#6180 closed defect (duplicate)

Downloader: SQL errors when accessing stats pages (and stats admin pages)

Reported by: muenchen@… Owned by: Ryan J Ollos
Priority: normal Component: TracDownloaderPlugin
Severity: major Keywords: stats
Cc: Trac Release: 0.11

Description (last modified by Ryan J Ollos)

When accessing the time stats, file stats, release stats or category stats pages in Downloader, OR when accessing the stats admin page of the Downloader, an sql error occurs. I manually checked in my sqlite db file, the tables are there.

The example shows when accessing Admin -> Downloader -> stats admin:

OperationalError: no such column: c.id

File "usr/pkg/lib/python2.5/site-packages/trac/web/main.py", line 423, in _dispatch_request
  dispatcher.dispatch(req)
File "usr/pkg/lib/python2.5/site-packages/trac/web/main.py", line 197, in dispatch
  resp = chosen_handler.process_request(req)
File "usr/pkg/lib/python2.5/site-packages/trac/admin/web_ui.py", line 114, in process_request
  path_info)
File "build/bdist.netbsd-5.0.1_PATCH-amd64/egg/tracdownloader/admin.py", line 137, in process_admin_requestFile "build/bdist.netbsd-5.0.1_PATCH-amd64/egg/tracdownloader/admin.py", line 229, in _serve_stats_adminFile "build/bdist.netbsd-5.0.1_PATCH-amd64/egg/tracdownloader/admin.py", line 383, in _render_stats_tableFile "build/bdist.netbsd-5.0.1_PATCH-amd64/egg/tracdownloader/model.py", line 987, in fetch_downloads_listFile "usr/pkg/lib/python2.5/site-packages/trac/db/util.py", line 50, in execute
  return self.cursor.execute(sql_escape_percent(sql), args)
File "usr/pkg/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 58, in execute
  args or [])
File "usr/pkg/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
  return function(self, *args, **kwargs)
System Information:

User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.22pre) Gecko/20090327 Ubuntu/8.04 (hardy) Firefox/2.0.0.22pre
Trac: 	0.11
Python: 	2.5.4 (r254:67916, Aug 11 2009, 15:28:54) [GCC 4.1.3 20080704 prerelease (NetBSD nb2 20081120)]
setuptools: 	0.6c9
SQLite: 	3.6.16
pysqlite: 	2.5.5
Genshi: 	0.5.1
mod_python: 	3.3.1
Pygments: 	1.0
Subversion: 	1.6.5 (r38866)
jQuery:	1.2.3

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 6 years ago by Ryan J Ollos

Owner: changed from Petr Škoda to Ryan J Ollos
Status: newassigned

#9068 closed as a duplicate.

comment:3 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: assignedclosed

Duplicate of #4214.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.