Modify

Opened 7 years ago

Closed 5 years ago

#6182 closed defect (duplicate)

unable to export static image in pdf (dynamic image works)

Reported by: anonymous Owned by: Diorgenes Felipe Grzesiuk
Priority: normal Component: TracWikiToPdfPlugin
Severity: normal Keywords: static image
Cc: Trac Release: 0.11

Description

I was unable to find any working configuration to export static image into the generated pdf. Dynamic image works like a charm (latex). TRAC : 0.11.5

To reproduce defect, configure apache and trac according to :

apache config file :

# this is where our html files go, access via https://www-foo.bar.fr
DocumentRoot /export/home/WWW-FOO/HTML-SSL
...
# /export/home/WWW-FOO/TRAC/pldes is wired as https://www-foo.bar.fr/pldes
<Location /pldes>
        SetHandler mod_python
        PythonInterpreter main_interpreter
        SetEnv TRAC_ENV /export/home/WWW-FOO/TRAC/pldes
        SetEnv PYTHON_EGG_CACHE /export/home/WWW-FOO/TMP/pldes
        PythonHandler trac.web.modpython_frontend
        PythonOption TracEnv /export/home/WWW-FOO/TRAC/pldes
        PythonOption TracUriRoot /pldes
</Location>

# in trac.ini

[wikitopdf]
base_dir = /export/home/WWW-FOO/TRAC/pldes
tmp_dir = /export/home/WWW-FOO/TMP
trac_uri = https://www-foo.bar.fr/pldes/

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #4043.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Diorgenes Felipe Grzesiuk.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.