Modify

Opened 7 years ago

Closed 6 years ago

#6238 closed defect (fixed)

[patch] upgrade doesn't handle absence of 'watchlist_version' from db with trac-0.12

Reported by: anonymous Owned by: martin_s
Priority: normal Component: WatchlistPlugin
Severity: normal Keywords: upgrade
Cc: Trac Release: 0.12

Description

Seemingly the 0.11 version of WatchlistPlugin is incompatible with trac 0.12 and a new branch has to be created.

The symptoms are: after installing (works only with 0.11 from source tar ball), the message "database needs to upgraded" appears and doesn't go away anymore. Doing "trac-admin /path/to/trac upgrade" does not help.

Attachments (3)

0002-fixes-needs_upgrade-bug.patch (1.1 KB) - added by doki_pen 7 years ago.
0003-fixes-bug-with-exception-message-formatting.patch (938 bytes) - added by anonymous 7 years ago.
0004-Fixes-bug-with-version-creation.patch (1.4 KB) - added by doki_pen 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by martin_s

  • Status changed from new to assigned

Dear anonymous, please have a look at BugReporting to learn how to report bugs. I need at least the revision number of WatchlistPlugin you installed. Your database backend would also be a important information. The error you describe looks more like #6166 (which is fixed) and not a 0.12 incompatibility. I'm also pretty sure that if this is a different bug then it could be fixed in a 0.11 compatible way which would avoid the need of a new branch.

comment:2 Changed 7 years ago by doki_pen

I'm not anonymouse, but I have the same problem. I've attached patches to fix the obvious bugs that cause the problem. I'm using revision 7110 of WatchList and revision 9163 of trac trunk.

Changed 7 years ago by doki_pen

Changed 7 years ago by doki_pen

comment:3 Changed 7 years ago by doki_pen

A final patch added. After restarting trac I realized that the former two patches didn't completely resolve the issue.

comment:4 Changed 7 years ago by hasienda

  • Keywords upgrade added
  • Summary changed from Does not work with 0.12 to [patch] database upgrade fails with trac-0.12

comment:5 Changed 7 years ago by hasienda

  • Summary changed from [patch] database upgrade fails with trac-0.12 to [patch] upgrade doesn't handle absence of 'watchlist_version' from db with trac-0.12

#6602 was closed as a duplicate of this one, already carried a reference

however, it has better description of the underlying problem:
"doesn't handle installations where the database doesn't contain a 'watchlist_version' gracefully"

comment:6 Changed 6 years ago by martin_s

Thanks a lot for the patches. I appreciate the contribution greatly. I created a Trac 0.12 branch and added the patches in [7976], [7977] and [7978], respectively.

I don't have Trac 0.12 installed at the moment and I'm too busy right now for any testing. Please verify if it's working on you installations so that I can close this ticket. Thanks!

comment:7 Changed 6 years ago by martin_s

  • Resolution set to fixed
  • Status changed from assigned to closed

I tested it now a little with a Trac 0.12 installation and can't find any errors. I'm closing this ticket now, please reopen it if there are any issues remaining.

Add Comment

Modify Ticket

Action
as closed The owner will remain martin_s.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.