Modify

Opened 8 years ago

Closed 7 years ago

#6309 closed defect (worksforme)

No Plugin Admin? (Confused by the docs)

Reported by: anonymous Owned by: Robert Corsaro
Priority: normal Component: AnnouncerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

The docs say:

The plugin itself is very modular, and exactly what features you have will depend on which modules you enable. You select modules in the 'Plugins' page of the 'Admin' section of your trac.

But when I go to my Trac admin page, I don't see anything there to configure the options listed in those docs.

Maybe I just don't understand the doc page... but I even did a CTRL-F search for "announcer" in the HTML source of my Trac admin page.

I got it to work by following the docs and editing my trac.ini directly, by editing [components] and setting announcerplugin.* = enabled.

Attachments (1)

PluginPanel.png (80.7 KB) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 8 years ago by anonymous

Another update...

I've looked at the docs page and my site does not reflect any of the new web GUI. I don't see the "Watch This" link, or any of the plugin Admin screens, or any way to opt out of notifications.

The AnnouncerPlugin works for me if I submit a ticket via email2trac, but none of the web GUI stuff seems to be enabled.

I am using a custom theme, however, my custom theme just has very minor tweaks to the native default Trac theme. I don't think that's the cause...?

comment:2 Changed 8 years ago by Ryan J Ollos

I suggest trying to configure trac.ini directly, as described here: wiki/AnnouncerPlugin#Installation.

Start with,

[components]
announcerplugin.* = enabled

Can you navigate to the Preferences panel for the AnnouncerPlugin in the metanav bar?

comment:3 in reply to:  2 Changed 8 years ago by anonymous

Replying to rjollos:

I suggest trying to configure trac.ini directly, as described here: wiki/AnnouncerPlugin#Installation.

Sorry, should have been: AnnouncerPlugin#Installation

comment:4 in reply to:  2 Changed 8 years ago by anonymous

Replying to rjollos:

I suggest trying to configure trac.ini directly, as described here: wiki/AnnouncerPlugin#Installation.

Start with,

[components]
announcerplugin.* = enabled

Sorry, I see now that you have already tried this.

comment:5 Changed 7 years ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

There is no special Announcer panel on the Admin page. The documentation is referring to the Plugin panel on the admin page (see screen capture below). If you don't see that, then you don't have it enabled in your Trac instance.

For managing settings, an Admin panel has been requested in #6255.

If you continue to have issues, please reopen the ticket.

Changed 7 years ago by anonymous

Attachment: PluginPanel.png added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Robert Corsaro.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.