Modify

Opened 7 years ago

Closed 6 years ago

Last modified 5 years ago

#6370 closed defect (worksforme)

502 Bad Gateway error when using ChangeLog in a comment of an open ticket

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Component: ChangeLogMacro
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

On Trac 0.11.4 I can use the plugin with no problem within a wiki page, but when adding markup such as the following to a ticket comment, I see a 502 Bad Gateway error after previewing or submitting the comment.

[[ChangeLog(/changelogplugin)]]

The error only occurs when the ticket is open, and disappears when the ticket has been closed (I can still close the ticket even when the error occurs using the Trac post-commit hook).

I haven't been able to reproduce on trac-hacks.org, which is running 0.10.6dev.

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by Ryan J Ollos

Owner: changed from Alec Thomas to Ryan J Ollos

Changing ticket owner since I have adopted the plugin.

comment:2 Changed 7 years ago by Ryan J Ollos

Component: ChangeLogPluginChangeLogMacro

comment:3 Changed 6 years ago by Ryan J Ollos

See #7879 for the same error seen with the CodeExampleMacro.

comment:4 Changed 6 years ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

This is an issue that seems to be specific to my hosting provider, so I'm closing the ticket for now and will reopen if they find a fix that requires changes to the ChangeLogMacro.

Modify Ticket

Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.