Opened 7 years ago

Closed 6 years ago

#6445 closed defect (worksforme)

installation issue with Trac 0.11.5 - Python-2.4 on linux

Reported by: jlukar@… Owned by: rjollos
Priority: high Component: TracHoursPlugin
Severity: normal Keywords: installation 0.11.5
Cc: Trac Release: 0.11

Description (last modified by rjollos)


I've been able to install the required plugins "ComponentDependencyPlugin" and "TicketSidebarProviderPlugin" but the .egg file for the TracHours doesn't seem to install at all. I don't see any errors in my <env>/log/track.log nor do I see any indication of faulty egg file created when I run "python setup bdist_egg" to create the egg file.

I had to manually add "trachours.* = enabled" to my [components] whereas componentdependencies and ticketsidebarprovider were added automatically when I dropped in the egg file to plugins.

Still the TracHours doesn't seem to install and I can't figure out why. Any ideas ?

componentdependencies.* = enabled
ticketsidebarprovider.* = enabled
trachours.* = enabled

Python 2.4.3 (#1, Sep 27 2006, 05:32:54) [GCC 3.4.6 20060404 (Red Hat 3.4.6-3)] on linux2

Attachments (1)

2010-01-18_1403.png (52.4 KB) - added by jlukar@… 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by jlukar@…

comment:1 Changed 6 years ago by patena@…

I have the same problem, with python 2.6, on ubuntu 9.10.

I tried running easy_install FeedParser and easy_install Python-DateUtil as per the instructions here (, no change.

comment:2 follow-up: Changed 6 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

Its probably easier for you to install from the update site:

If you want to install from the zip archive, you do so from the the Help > Software Updates dialog.

Please reopen if you have unresolved issues.

comment:3 in reply to: ↑ 2 Changed 6 years ago by rjollos

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Whoops, posted to wrong ticket. Sorry.

comment:4 Changed 6 years ago by slatem@…

  • Priority changed from normal to high

Having this same issue, unable to install in 0.11.5.

comment:5 Changed 6 years ago by AdrianFritz

  • Keywords installation added; instllation removed

comment:6 Changed 6 years ago by rjollos

  • Description modified (diff)
  • Owner changed from k0s to rjollos
  • Status changed from reopened to new

I believe this is fixed now, and easy_install will handle all of the dependencies. I have installed and tested both 0.11 and 0.12.

Please reopen if you continue to have issues.

comment:7 Changed 6 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.