Modify

Opened 11 years ago

Closed 11 years ago

#645 closed enhancement (duplicate)

p4 client option

Reported by: excentric@… Owned by: ttressieres
Priority: normal Component: PerforcePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

I'd like to be able to specify a p4 client in my trac.ini - more specifically i want to set up trac and the perforce plugin to only view one or a more paths and not everything under depot.

If this is already possible, the wiki should speak of it.

(as a side note - the perforce server here was rebooted in the middle of the plugin looking through the change/revision history - when the server came back and i tried to force my trac site to browse the source again - i got an error similar to the following "column rev not unique" wiping the node and revision tables allowed me to continue)

Cheers Sean

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by Lewis Baker

This can be done in a round-about way at the moment by using 'p4 protect' to limit access of the Perforce user specified in the trac.ini file to particular areas of the repository.

A more general mechanism for limiting the view of the repository for particular projects is something that would be worthwhile, though.

Also, the problem you mention as a side note is probably worth a separate ticket.

comment:2 Changed 11 years ago by Lewis Baker

The issue described in the side note has been moved to ticket #659.

comment:3 Changed 11 years ago by Lewis Baker

Resolution: duplicate
Status: newclosed

Duplicate of #694.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ttressieres.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.