Modify

Opened 7 years ago

Closed 7 years ago

#6515 closed defect (fixed)

Roadmap total hours not updating

Reported by: frederik.charest@… Owned by: Jeff Hammel
Priority: normal Component: TracHoursPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Adding time to a ticket that existed before the plugin was installed doesn't seem to update the roadmap.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

For me too.

comment:2 Changed 7 years ago by anonymous

Resolution: fixed
Status: newclosed

The problem is that in file web_ui.py at line 95 the seconds are transformed into hours, but this is done each time a ticket is processed. So for the first ticket, its total time (in seconds) is added and transformed correctly to the milestone's total time (in hours), but when the next tickets are processed, their time (in seconds) is added to the existing milestone's total time (in hours) and then transformed again in hours. So the preexisting milestone's total time (in hours) is divided by 3600 again.

Fix by putting lines 94 and 95 outside the tickets' for clause.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jeff Hammel.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.