Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#6626 closed defect (fixed)

Layout issue when box width overlaps with PageOutline macro

Reported by: Ryan J Ollos Owned by: Alexander Slesarev
Priority: normal Component: CodeExampleMacro
Severity: normal Keywords:
Cc: Hohenems Trac Release: 0.11

Description

I see this issue when using the PageOutline macro, but it would probably occur with any box in the sidebar, such as the NewsFlashMacro or FullBlogPlugin BlogList macro.

Here is the wiki markup:

[[PageOutline(2-5,Code Examples,pullout)]]

= Code Examples =

== Simple Code Example ==
{{{
#!CodeExample
#!python
    def apply_timer(self):
        timer = QTimer(self)
        self.connect(timer, SIGNAL('timeout()'), self.update_statusbar)
        timer.start(settings.HINTS_UPDATE_PERIOD)
}}}

== Bad Code Example ==
{{{
#!BadCodeExample
#!python
    def create_hint_list(self):
        self.hints.extend(self.globals.get_hint_list())
}}}

Attachments (2)

OverlapWithPageOutlineMacro.png (51.1 KB) - added by Ryan J Ollos 8 years ago.
LayoutIssueInSeaMonkey.png (60.2 KB) - added by Ryan J Ollos 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by Ryan J Ollos

comment:1 Changed 8 years ago by Alexander Slesarev

Status: newassigned

comment:2 Changed 8 years ago by Ryan J Ollos

Possibly related is the following layout issue in the SeaMonkey browser.

Changed 8 years ago by Ryan J Ollos

Attachment: LayoutIssueInSeaMonkey.png added

comment:3 Changed 8 years ago by Alexander Slesarev

The issue with SeaMonkey is related with the "float:right" attribute I've added recently. Unfortunately, I don't know how to fix it correctly, but in other modern browsers it works fine.

comment:4 Changed 8 years ago by Alexander Slesarev

Resolution: fixed
Status: assignedclosed

The subj issue have been fixed in r7624.

comment:5 Changed 8 years ago by Ryan J Ollos

Thanks for fixing that, it looks really good now. I wasn't worried about the SeaMonkey issue, I just pointed it out in case it helped with reproducing layout problems. Looks like you might have fixed that as well though in [7627]? I won't be able to test all the other changes for a few days since my Ubuntu VM decided to stop booting up today.

comment:6 Changed 7 years ago by physical therapist

Cc: Hohenems added; anonymous removed

Keep posting stuff like this i really like it

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Alexander Slesarev.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.