Modify

Opened 8 years ago

Closed 7 years ago

#6661 closed defect (worksforme)

Coloring issue for GoodCodeExample and BadCodeExample

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Component: CodeExampleMacro
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I upgraded to [7633] and haven't had time to test out the change to the *Path functions yet, but thank you very much for implementing those quickly.

One minor thing I noticed today and was able to reproduce with several browsers occurs when using the GoodCodeExample or BadCodeExample macro and the simple/good example from the CodeExampleMacro wiki page:

System details:

Trac:	0.11.4
Python:	2.4.3 (#1, Sep 3 2009, 15:37:37) [GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
setuptools:	0.6c11
SQLite:	3.3.6
pysqlite:	2.3.3
Genshi:	0.5.1
Subversion:	1.5.7 (r36142)
mod_python:	3.2.8
Pygments:	1.1.1
FullBlog:	0.1.1-r7225
jQuery:	1.2.6

Attachments (2)

ColorIssue.png (16.7 KB) - added by Ryan J Ollos 8 years ago.
sample.png (28.2 KB) - added by Alexander Slesarev 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Ryan J Ollos

Attachment: ColorIssue.png added

Changed 8 years ago by Alexander Slesarev

Attachment: sample.png added

comment:1 Changed 8 years ago by Alexander Slesarev

Owner: changed from Alexander Slesarev to Ryan J Ollos

Can't reproduce. Actually, it looks like your Pygments is using different color scheme or broken. See below a screenshot from Pygments 1.1.1 (the latest version gives the same colors):

Tested with:

  • Configuration 1 (Ubuntu 9.10):
    • Trac 0.12dev-r8583
    • Python 2.6.4
    • setuptools 0.6c9
    • Genshi 0.6dev-r1064
    • Pygments 1.0-3
  • Configuration 1 (WinVista):
    • Trac 0.11.6
    • Python 2.4.4
    • setuptools 0.6c11
    • Genshi 0.5.1
    • Pygments 1.1.1 (and 2.2.2)

comment:2 Changed 7 years ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

I'm no longer seeing this issue, which I suspect was resolved by upgrading Pygments, as you suggested.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.