Modify

Opened 8 years ago

Closed 7 years ago

#6847 closed defect (wontfix)

To enable connecting with NoUserID (for Testlink integration)

Reported by: Tian Bai Owned by: Odd Simon Simonsen
Priority: normal Component: XmlRpcPlugin
Severity: normal Keywords: Testlink
Cc: Tian Bai Trac Release: 0.11

Description

Currently, I have to use 'anonymous' as the username to connect with xmlrpc:

import xmlrpclib
server = xmlrpclib.ServerProxy("http://'''anonymous'''@server/trac/project/xmlrpc") 
multicall = xmlrpclib.MultiCall(server) 
for ticket in server.ticket.query("id=1"): 
    multicall.ticket.get(ticket) 
print map(str, multicall())

If I use a blank username (NoUserID is configured to be On with Apache):

server = xmlrpclib.ServerProxy("http://server/trac/project/xmlrpc") 

It returned the error "401 Authorization Required".

The problem is that it seems Testlink connects to Trac with a blank username, so it fails unless I hack Testlink's code.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Odd Simon Simonsen

Resolution: wontfix
Status: newclosed

That is quite an intricate set of authentication config details for a particular purpose, but I fail to see how it is an issue for the RPC plugin - or even what is expected to change in the plugin to fix this? The RPC plugin don't provide authentication. Apache does, and it is read and configured by Trac itself long before it arrives at plugin code.

I'm closing this. Please reopen if I haven't understood the issue correctly.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Odd Simon Simonsen.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.