Modify

Opened 8 years ago

Closed 3 weeks ago

Last modified 3 weeks ago

#6891 closed enhancement (fixed)

Disable IP banning

Reported by: haf@… Owned by: Ryan J Ollos
Priority: normal Component: MathCaptchaPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Is there a way to disable IP banning? In our trac, we regularly get the "System offline." message although none of us has used the system anonymously and failed any captchas. So the spam bot produces false-positives that prevent us from any access.

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by Rob McMullen

Status: newassigned

I'll look into adding a parameter that controls that.

In the meantime, you can edit the MathCaptcha.py source and at line 84 change ban_after_failed_attempts to some large integer.

comment:2 Changed 8 years ago by haf@…

I investigated this issue further: The problem is, that our trac runs on a dedicated machine behind mod_proxy of the Apache webserver. This means that all requests get tunneled through the webserver and forwarded to the trac server. Therefore all requests at trac have the same IP address, namely the one of the webserver. Hence all spam requests together with all good requests have the same IP. Hence filtering by IP is no good idea on the trac level.

I image, many bigger projects or institutions would want to use mod_proxy which seems to be not working with MathCaptcha.

comment:3 Changed 3 weeks ago by Ryan J Ollos

Owner: changed from Rob McMullen to Ryan J Ollos

comment:4 Changed 3 weeks ago by Ryan J Ollos

Resolution: fixed
Status: assignedclosed

In 17090:

TracMathCaptcha 5.0dev: Add option ban_after_failed_attempts

This also fixes two defects that led to the number of
failures being miscounted.

Fixes #6891.

comment:5 Changed 3 weeks ago by Ryan J Ollos

In 17091:

TracMathCaptcha 5.0dev: Fix grammar in option doc

Refs #6891.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.