Opened 12 years ago

Closed 8 years ago

#7123 closed defect (wontfix)

Not working with trac0.1x version ending

Reported by: Stefan Simroth Owned by: CuriousCurmudgeon
Priority: low Component: BatchModifyPlugin
Severity: minor Keywords:
Cc: Trac Release: 0.11


I am using Trac 0.11.7 from lenny-backports on a Debian Linux w/ Apache.

I just tried to install the pre-compiled egg and a custom cooked one from the 0.5 version, but it wouldn't start working. Trac was logging to the DEBUG log that it got installed correctly, after I uploaded it via Web Admin UI.

But I received no error what so ever, not even with logging set to DEBUG!

It just wouldn't work.

I removed the -trac0.11 suffix from the version number, cooked and installed - and it's working!

Had the same issue with another plugin today that was tagged as dev and with the revision number, so sth like "0.3dev_rev1234" and it wouldn't work. Removing all that stuff made the plugin work...

What kind of bug is that? I tend to believe it's with Trac and not with BatchModifyPlugin, but as you started using the version suffix, some other people might run into this issue, too...

Attachments (1)

BatchModify-0.8.0-py2.4.egg (13.5 KB) - added by ralf.wohner@… 12 years ago.
0.8.0-Egg for Trac 0.11 compiled with python 2.4

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by CuriousCurmudgeon

Status: newassigned

I am unable to reproduce this on either of the following:

  • 0.11.4 with Python 2.5.4
  • 0.12 (trunk) with Python 2.6.5

Can anybody else reproduce this?

comment:2 Changed 12 years ago by CuriousCurmudgeon

#7435 may be related to this.

comment:3 Changed 12 years ago by Mazda86

I'm using a custom-compiled Python 2.4.5 with Trac 0.11.7 and am seeing the same issue. Same fix (remove the -trac-0.11 suffix from VERSION in, recook, and reinstall) worked for me as well.

So maybe the common denominator here is Trac 0.11.7 ?

comment:4 Changed 12 years ago by ralf.wohner@…

I guess the problem is the python version. Enterprise linuxes still tend to use 2.4.x, the developers here seem to use 2.5.x and 2.6.x which currently aren't available for many enterprises.

Would be nice if the pre-built download table would also contain eggs for 2.4.x

comment:5 Changed 12 years ago by CuriousCurmudgeon

Feel free to contribute 2.4 eggs. I will add them. The only reason I don't supply them is because I don't have 2.4 installed anymore.

Changed 12 years ago by ralf.wohner@…

Attachment: BatchModify-0.8.0-py2.4.egg added

0.8.0-Egg for Trac 0.11 compiled with python 2.4

comment:6 Changed 8 years ago by Ryan J Ollos

Resolution: wontfix
Status: assignedclosed

The plugin is deprecated since it has been integrated to the Trac core for 1.0. Upgrade to Trac 1.0 and uninstall this plugin to get the latest functionality. Enhancement requests can be directed to Trac.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain CuriousCurmudgeon.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.