Modify

Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#7138 closed defect (duplicate)

ProgrammingError: Cannot operate on a closed cursor.

Reported by: dwozniak Owned by: anonymous
Priority: high Component: TracPastePlugin
Severity: normal Keywords: ProgrammingError, closed, cursor
Cc: roland.kaercher@… Trac Release: 0.11

Description

How to Reproduce

While doing a GET operation on /pastebin, Trac issued an internal error.

Request parameters:

{'new_paste': True, 'paste_id': None}

User Agent was: Opera/9.80 (Windows NT 6.1; U; pl) Presto/2.5.24 Version/10.53

System Information

Trac 0.11.6
Python 2.6.4 (r264:75706, May 13 2010, 20:32:36)
[GCC 3.4.6 (Gentoo Hardened 3.4.6-r2 p1.5, ssp-3.4.6-1.0, pie-8.7.10)]
setuptools 0.6
SQLite 3.6.17
pysqlite 2.5.5
Genshi 0.5.1
Pygments 1.0
Subversion 1.6.5 (r38866)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/site-packages/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/home/projects/oferta/trac/plugins/TracPaste-0.2-py2.6.egg/tracpaste/web_ui.py", line 141, in process_request
    'recent':           get_pastes(env=self.env, number=self.max_recent)
  File "/home/projects/oferta/trac/plugins/TracPaste-0.2-py2.6.egg/tracpaste/model.py", line 53, in get_pastes
    cursor.execute(sql, where_values)
  File "/usr/lib/python2.6/site-packages/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql)
  File "/usr/lib/python2.6/site-packages/trac/db/sqlite_backend.py", line 80, in execute
    PyFormatCursor.execute(self, *args)
  File "/usr/lib/python2.6/site-packages/trac/db/sqlite_backend.py", line 59, in execute
    args or [])
  File "/usr/lib/python2.6/site-packages/trac/db/sqlite_backend.py", line 51, in _rollback_on_error
    return function(self, *args, **kwargs)
ProgrammingError: Cannot operate on a closed cursor.

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by anonymous

Owner: changed from Michael Renzmann to anonymous
Status: newassigned

comment:2 Changed 7 years ago by anonymous

Cc: roland.kaercher@… added; anonymous removed
Priority: normalhigh

Happens in the timeline, too.

comment:3 Changed 7 years ago by Ryan J Ollos

Resolution: duplicate
Status: assignedclosed

Duplicate of #6341.

comment:4 Changed 3 years ago by Ryan J Ollos

Keywords: ProgrammingError closed cursor added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.