Modify

Opened 11 years ago

Closed 4 years ago

#717 closed defect (duplicate)

Multiple unix groups

Reported by: anonymous Owned by: Noah Kantrowitz
Priority: normal Component: UnixGroupsPlugin
Severity: normal Keywords: needinfo
Cc: nick.stone@… Trac Release: 0.10

Description

I have set up trac to authenticate from AD and have set up a map so that certain users map to the UNIX group tracadmin. I have checked out the process and I definitely have tracadmin group permissions assoicated with the user.

I suspect (well in fact know) that the user is part of more than one group and it appears that only the first group in the range is matched against the permissions list with the result that no rights are assigned. From the code it looks as though other groups are being picked up and I was wondering whether it was possible to make the plugin such that it would try and match all the groups in the list until such time as a match was found or no more groups were listed. Or may be, again looking at the code (I'm very new to Python!), this isn't the right place for this change.

Nick

Attachments (0)

Change History (6)

comment:1 Changed 11 years ago by anonymous

Type: enhancementdefect

I have a bit more information it appears the proble is that the username being passed in is set to anonymous as opposed to the user that has logged in - this may be a problem with apache I guess but I'm happy to try a few things here if it helps - let me know if you need more information

comment:2 Changed 11 years ago by anonymous

A couple of things that might help. The username on the log in text is correct (i.e. when you log-in the username used comes up in the Logged in as XXXX). Also if you fix the username in the module it works fine so it look as though the username isn't being passed in correctly - possibly? I added some logging to the file and the module is definitely doing the get groups bit OK but the username does appear completely wrong.

comment:3 Changed 11 years ago by anonymous

One last thing I'm using the 0.10 version on Python 2.4 with trac Trac 0.10b1

comment:4 Changed 11 years ago by Noah Kantrowitz

Keywords: needinfo added
Trac Release: 0.90.10

Are you still seeing this problem with a release version of Trac (either 0.10 or 0.10.1)?

comment:5 Changed 10 years ago by techcon1@…

I ran into the same problem (it's inherent to the python grp module), and fixed it myself: #1818.

comment:6 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Closing as duplicate of #1818 since that ticket has a patch.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.