Modify

Opened 7 years ago

Closed 7 years ago

#7468 closed defect (fixed)

[patch] Layout of page with a pullout (sidebar) macro is affected

Reported by: Ryan J Ollos Owned by: Steffen Hoffmann
Priority: normal Component: WikiTicketCalendarMacro
Severity: major Keywords: CSS div table width
Cc: Trac Release: 0.11

Description

The issue is demonstrated in the following two screen captures.

Here is my home page without the WikiTicketCalendarMacro at that bottom of the page. You can see that I have a sidebar from the FullBlogPlugin displayed near the top of the page, and some wiki tables to the left.

Here is my home page with the WikiTicketCalendarMacro at the bottom of the page. You can see that the wiki tables are no longer displayed to the left of the FullBlogPlugin sidebar, but have been pushed down the page.

I can't say for certain that this is a problem with the WikiTicketCalendarMacro, but I did not observe this behavior with release 0.8.5 and 0.8.5 beta versions. The problem appeared upon installing 0.8.6.

Attachments (6)

WithWikiTicketCalendarMacro.png (147.3 KB) - added by Ryan J Ollos 7 years ago.
WithoutWikiTicketCalendarMacro.png (270.5 KB) - added by Ryan J Ollos 7 years ago.
7468-fix_remove-div-width.patch (917 bytes) - added by Steffen Hoffmann 7 years ago.
proposed change to remove width def suspected to cause bad HTML
wikiticketcalendar_screenshot_1-2-2_no-data.png (7.9 KB) - added by Steffen Hoffmann 7 years ago.
screenshot of WikiTicketCalendarMacro 1.2.2 collapsed to minimal size due to lack of milestone and ticket information
WithMilestones.png (37.5 KB) - added by anonymous 7 years ago.
WithoutMilestones.png (27.0 KB) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (17)

Changed 7 years ago by Ryan J Ollos

Changed 7 years ago by Ryan J Ollos

comment:1 Changed 7 years ago by Ryan J Ollos

Note: I accidentally mixed up the order of the attachments and description in the Ticket Description.

comment:2 Changed 7 years ago by Steffen Hoffmann

Keywords: CSS div width added
Severity: normalmajor
Status: newassigned

Looks ugly indeed, so at least +1 for severity.

Oh yeah, that could very well be the case. Maybe I did some changes regarding x-axis scaling in between. I'll take a look at this, but with your info this is already narrowed down considerable.

But wait, since I fixed CSS lately, a broken behavior might have been there for longer, but wasn't observable before. - Confirmed. This seems like I added width="100%" to surrounding div-section in changeset [8263] for 0.8.4, but the flawed CSS at the same time.

I'll provide a patch tomorrow, and fix this in repo then, provided you'll confirm that it works for you. Thanks for testing.

comment:3 in reply to:  2 Changed 7 years ago by Ryan J Ollos

Replying to hasienda:

I'll provide a patch tomorrow, and fix this in repo then, provided you'll confirm that it works for you. Thanks for testing.

Certainly, I look forward to testing the new version.

Changed 7 years ago by Steffen Hoffmann

proposed change to remove width def suspected to cause bad HTML

comment:4 Changed 7 years ago by Steffen Hoffmann

Summary: Layout of page with a pullout (sidebar) macro is affected[patch] Layout of page with a pullout (sidebar) macro is affected

Please try the attached patch, or just hand-edit the small change to your WikiTicketCalendarMacro file 0.8.6. For 1.2.1 a similar change would be done in the CSS file and both committed instantly, if your test is positive. Thanks for taking care.

comment:5 Changed 7 years ago by Ryan J Ollos

The patch seems to be working well. Thanks!

Changed 7 years ago by Steffen Hoffmann

screenshot of WikiTicketCalendarMacro 1.2.2 collapsed to minimal size due to lack of milestone and ticket information

comment:6 Changed 7 years ago by Steffen Hoffmann

The consequence of removing the explicit width setting from the div tag surrounding the whole HTML table is, that the calendar is displayed with minimal width that fits all content in one row (see attached screenshot image).

So without additional data the calendar now collapses significantly. However I've prepared a new version at the current state, since the initial issue is solved indeed.

This might be enough, or not. Depending on further user response it could be worth another option, i.e. table_fixed-width=<valid_CSS_size>, where you could set total width in pixel or % of page width as required. Any comments?

Changed 7 years ago by anonymous

Attachment: WithMilestones.png added

Changed 7 years ago by anonymous

Attachment: WithoutMilestones.png added

comment:7 Changed 7 years ago by Ryan J Ollos

I can confirm the behavior you describe,

With data:


Without data:

comment:8 Changed 7 years ago by Ryan J Ollos

I'd definitely prefer a setting that allows the width of the calendar to be controlled. The way it I currently use WikiTicketCalendarMacro, I'd prefer it to span the width of the page.

comment:9 in reply to:  8 ; Changed 7 years ago by Steffen Hoffmann

Keywords: table added

Replying to rjollos:

I'd definitely prefer a setting that allows the width of the calendar to be controlled. The way it I currently use WikiTicketCalendarMacro, I'd prefer it to span the width of the page.

I take this a vote for my previous suggestion, right?

comment:10 in reply to:  9 Changed 7 years ago by Ryan J Ollos

Replying to hasienda:

I take this a vote for my previous suggestion, right?

Yes, +1 from me. I'd find the % of page width as required option to be most immediately useful.

comment:11 Changed 7 years ago by Steffen Hoffmann

Resolution: fixed
Status: assignedclosed

(In [8357]) WikiTicketCalendarMacro: Add flexible calendar display width control, closes #7468.

Forced width by div HTML tag is made optional now, and CSS attribute 'min-width' should be less forceful against other page layout constraints.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.