Modify

Opened 7 years ago

Closed 7 years ago

#7583 closed defect (worksforme)

trac-admin upgrade wrong

Reported by: anonymous Owned by: Odd Simon Simonsen
Priority: highest Component: FullBlogPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description (last modified by Odd Simon Simonsen)

Traceback info:

Traceback (most recent call last):
  File "/usr/local/bin/trac-admin", line 9, in <module>
    load_entry_point('Trac==0.11.7', 'console_scripts', 'trac-admin')()
  File "/usr/lib/python2.6/dist-packages/trac/admin/console.py", line 1321, in run
    return admin.onecmd(command)
  File "/usr/lib/python2.6/dist-packages/trac/admin/console.py", line 138, in onecmd
    rv = cmd.Cmd.onecmd(self, line) or 0
  File "/usr/lib/python2.6/cmd.py", line 219, in onecmd
    return func(arg)
  File "/usr/lib/python2.6/dist-packages/trac/admin/console.py", line 1159, in do_upgrade
    self.__env.upgrade(backup=do_backup)
  File "/usr/lib/python2.6/dist-packages/trac/env.py", line 462, in upgrade
    self.backup(backup_dest)
  File "/usr/lib/python2.6/dist-packages/trac/env.py", line 430, in backup
    return DatabaseManager(self).backup(dest)
  File "/usr/lib/python2.6/dist-packages/trac/db/api.py", line 120, in backup
    return connector.backup(dest)
  File "/usr/lib/python2.6/dist-packages/trac/db/mysql_backend.py", line 173, in backup
    p = Popen(args, env=environ, stderr=PIPE, close_fds=close_fds)
  File "/usr/lib/python2.6/subprocess.py", line 633, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1139, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

if i remove the plugin ,no error!

my mysql server is in another host!

thank you!!

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Odd Simon Simonsen

Description: modified (diff)
Resolution: worksforme
Status: newclosed

I don't quite see how this is a plugin issue. From what I see the problem is in Trac itself where any upgrade will call the backend backup routine, which from what I read from the traceback factors out to subprocess.Popen(). This is basically regular shell tools, and it likely don't find the necessary tools as the local machine does not have mysql installed.

Anyway, my guess is that any plugin that needs upgrades will crash the same way. I suggest you make a db copy manually, and then turn off backup on the trac-admin upgrade command using the --no-backup (or -b) option when running.

Please reopen ticket if I got this all wrong.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Odd Simon Simonsen.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.