Modify

Opened 7 years ago

Closed 7 years ago

#7702 closed defect (duplicate)

Switch from deprecated `sha` module to modern `hashlib` [patch]

Reported by: Stjujsckij Nickolaj Owned by: Peter Kropf
Priority: normal Component: GraphvizPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Running Trac with GraphvizPlugin installed results in lots of errors like

DeprecationWarning: the sha module is deprecated; use the hashlib module instead

Simple patch against HEAD fixing the issue is attached.

Attachments (1)

trac_grv.patch (790 bytes) - added by Stjujsckij Nickolaj 7 years ago.
sha->hashlib

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Stjujsckij Nickolaj

Attachment: trac_grv.patch added

sha->hashlib

comment:1 Changed 7 years ago by Stjujsckij Nickolaj

Cc: anonymous added; Stjujsckij Nickolaj removed
Resolution: duplicate
Status: newclosed

Sorry, should search tickets first.

Duplicate of #5747

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Peter Kropf.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.